summaryrefslogtreecommitdiff
path: root/dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild')
-rw-r--r--dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild b/dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild
new file mode 100644
index 000000000000..c2f3eb2a2f0e
--- /dev/null
+++ b/dev-perl/Sub-Quote/Sub-Quote-2.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.004000
+inherit perl-module
+
+DESCRIPTION="Efficient generation of subroutines via string eval"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !<dev-perl/Moo-2.3.0
+ !minimal? (
+ >=dev-perl/Sub-Name-0.80.0
+ )
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"