summaryrefslogtreecommitdiff
path: root/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild')
-rw-r--r--dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild b/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
new file mode 100644
index 000000000000..4369b68005b8
--- /dev/null
+++ b/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.003001
+inherit perl-module
+
+DESCRIPTION="efficient generation of subroutines via string eval"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !<dev-perl/Moo-2.3.0
+ !minimal? (
+ >=dev-perl/Sub-Name-0.80.0
+ )
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"