summaryrefslogtreecommitdiff
path: root/dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild')
-rw-r--r--dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild b/dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild
new file mode 100644
index 000000000000..369ca91291fb
--- /dev/null
+++ b/dev-perl/Sub-Identify/Sub-Identify-0.140.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RGARCIA
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="Retrieve names of code references"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/pod.t"
+ perl-module_src_test
+}