summaryrefslogtreecommitdiff
path: root/dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild')
-rw-r--r--dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild
new file mode 100644
index 000000000000..3ef7d21679ec
--- /dev/null
+++ b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=YVES
+DIST_VERSION=4.004
+inherit perl-module
+
+DESCRIPTION="Fast, compact, powerful binary serialization"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# Note: bundled zstd fails compile
+RDEPEND="
+ virtual/perl-XSLoader
+ app-arch/zstd:=
+"
+# Tester note: ideally you want dev-perl/Sereal-Decoder
+# as well, but we can't depend on it because it forms
+# a tight cycle if we do
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-7.0.0
+ >=virtual/perl-ExtUtils-ParseXS-2.210.0
+ virtual/perl-File-Path
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Test-Deep
+ dev-perl/Test-Differences
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warn
+ )
+"