summaryrefslogtreecommitdiff
path: root/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild
new file mode 100644
index 000000000000..a2cdfad546c9
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/xapian:0/1.2.22
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Devel-Leak )
+"
+
+DIST_TEST=do
+# parallel fails sometimes...
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}