summaryrefslogtreecommitdiff
path: root/dev-perl/SVG/SVG-2.820.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-perl/SVG/SVG-2.820.0.ebuild
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-perl/SVG/SVG-2.820.0.ebuild')
-rw-r--r--dev-perl/SVG/SVG-2.820.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/SVG/SVG-2.820.0.ebuild b/dev-perl/SVG/SVG-2.820.0.ebuild
new file mode 100644
index 000000000000..1511b8f5323a
--- /dev/null
+++ b/dev-perl/SVG/SVG-2.820.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=2.82
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl extension for generating Scalable Vector Graphics (SVG) documents"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-parent
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+src_test() {
+ perl_rm_files t/96-perl-critic.t t/98-tidyall.t \
+ t/99_test_pod_coverage.t \
+ t/meta-json.t \
+ t/meta-yml.t
+ perl-module_src_test
+}