summaryrefslogtreecommitdiff
path: root/dev-perl/SOAP-WSDL
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/SOAP-WSDL
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/SOAP-WSDL')
-rw-r--r--dev-perl/SOAP-WSDL/Manifest5
-rw-r--r--dev-perl/SOAP-WSDL/SOAP-WSDL-3.3.0.ebuild60
-rw-r--r--dev-perl/SOAP-WSDL/metadata.xml134
3 files changed, 199 insertions, 0 deletions
diff --git a/dev-perl/SOAP-WSDL/Manifest b/dev-perl/SOAP-WSDL/Manifest
new file mode 100644
index 000000000000..703ce6435041
--- /dev/null
+++ b/dev-perl/SOAP-WSDL/Manifest
@@ -0,0 +1,5 @@
+DIST SOAP-WSDL-3.003.tar.gz 238159 SHA256 84f6b542d95d60211bf94cc098677c19529a897950b93461945a726d345cfcbd SHA512 a74416ea1208f589ddde3799856e9cb7c495e5d6c31aa0e8659abfcbf21bcaa9570200c5b86746401a7566d8de25c4a7ba4338828830d11f7b66f2abb424b2b3 WHIRLPOOL e42e7aefc646830a3085c7dbd6e38ff98cb6079627e789fc84ec466af529e8b6d508d54088a8c087284db4709e9e583dfe729fe38f27648e3950e30019d3ed13
+EBUILD SOAP-WSDL-3.3.0.ebuild 1256 SHA256 dd2b51b6635477968e281faffbce20412a3ad57127a64a77cbd47498347530ce SHA512 8f8cc4eb042018357933c4f0a44d4a4fa343cde79c0f032ac004b6f8cdebf8896b49dd73d1914d5743798b1f85037f79235fee0869bfd8360f9d3c255f1822fa WHIRLPOOL 73abdb2b2068ad6f102fd862f5a34ee49bd1e0c81a261b87bfe01bbafc1dc20c9883cde019bb37f0993480660aced87bc50070a55a923d6ce12d04ec4b5eb0a6
+MISC ChangeLog 3145 SHA256 6bfd04631a273ad415bd96a9ab97b194ff5d2bd5404156e80befd19fd7ab89d3 SHA512 a2723523065048a795b6a82212d434f764368c78a4ff3b50698875abf414d7cda16b751ebe56c3e63e51923e60d3b75d01d55dfa8499d7e3d94f6c4563051e04 WHIRLPOOL 696e007334340cd9b006c79c1ef36fd90fe83723857301619b180a9e4f751b06b0f206a2455e257de7a7f1cc37d073fa62987d37d8c14f420f5417ffb95a0a9b
+MISC ChangeLog-2015 1161 SHA256 ce663dbef1cfff2a6f1fce30b5a74c49900cacbd60a12a2faae2f7810dc5d57b SHA512 e78aed033d7a5e07cb52943ac6cc6565653eabc1880d7b413a3c4a1beeeff95e5c76153de1289c242cfa1e380a6f09aca7c3cc8feb8baa7b79c2ca6cb0990559 WHIRLPOOL 6e50dc64ef320a818c56ebe3992cad28d6dc883e2e4d7c4a4b926db9844f959aa14d123f2ee0575c60d5903ff8f7a3a91d156dd9f2d17aa86b4e6cf0c21a36c7
+MISC metadata.xml 10195 SHA256 4150c40a387abc08dd3eec15ec1ec0b27a08795d15c61452d59da5743e446302 SHA512 a78e57226182511affcb188d1a58b246fc74a2c31684e6b991c62636df66afe923a88edc91572a6324f6932496f42428a179e21d24fbd890ad638eeea80c4d16 WHIRLPOOL f81bb6104aa3d341ac142397017d9f211c8b4e79cd4071b072a6d3d1be5d18f1e152fa232144e47cd74186ea036ffaf498d98c7d7a24f46f12c35c4bf9a1a6bb
diff --git a/dev-perl/SOAP-WSDL/SOAP-WSDL-3.3.0.ebuild b/dev-perl/SOAP-WSDL/SOAP-WSDL-3.3.0.ebuild
new file mode 100644
index 000000000000..a7b281004672
--- /dev/null
+++ b/dev-perl/SOAP-WSDL/SOAP-WSDL-3.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=3.003
+DIST_AUTHOR=SWALTERS
+inherit perl-module
+
+DESCRIPTION="SOAP with WSDL support"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ >=dev-perl/Class-Load-0.200.0
+ >=dev-perl/Class-Std-Fast-0.0.5
+ virtual/perl-Data-Dumper
+ dev-perl/TimeDate
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ dev-perl/libwww-perl
+ dev-perl/Module-Build
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Template-Toolkit-2.180.0
+ dev-perl/TermReadKey
+ dev-perl/URI
+ dev-perl/XML-Parser
+"
+
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/CGI
+ virtual/perl-Test-Simple
+ virtual/perl-Getopt-Long
+ virtual/perl-Storable
+ )
+"
+DIST_TEST="do" # parallel testing dies
+src_prepare() {
+ perl-module_src_prepare
+ perl_rm_files test_html.pl
+}
+src_test() {
+ perl_rm_files t/098_pod.t t/099_pod_coverage.t t/094_cpan_meta.t t/095_copying.t t/096_characters.t t/097_kwalitee.t
+ perl-module_src_test
+}
+src_install() {
+ perl-module_src_install
+ dodoc MIGRATING
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r example/*
+ fi
+}
diff --git a/dev-perl/SOAP-WSDL/metadata.xml b/dev-perl/SOAP-WSDL/metadata.xml
new file mode 100644
index 000000000000..e85029a265a1
--- /dev/null
+++ b/dev-perl/SOAP-WSDL/metadata.xml
@@ -0,0 +1,134 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">SOAP-WSDL</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Base</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Binding</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Client::Base</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Definitions</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Deserializer::Hash</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Deserializer::SOM</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Deserializer::XSD</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Expat::Base</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Expat::Message2Hash</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Expat::MessageParser</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Expat::MessageStreamParser</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Expat::WSDLParser</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Factory::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Factory::Generator</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Factory::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Factory::Transport</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Iterator::WSDL11</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::PrefixResolver</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Template</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Template::Plugin::XSD</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Template::XSD</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Visitor</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Generator::Visitor::Typemap</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Message</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::OpMessage</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Operation</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Part</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Port</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::PortType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Address</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Body</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Header</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::HeaderFault</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Operation</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Typelib::Fault</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::SOAP::Typelib::Fault11</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Serializer::XSD</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Server::CGI</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Server::Mod_Perl2</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Server::Simple</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Service</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Transport::Loopback</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Transport::Test</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::TypeLookup</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::Types</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Annotation</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Attribute</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::AttributeGroup</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Builtin</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::ComplexType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Element</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Enumeration</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::FractionDigits</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Group</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Length</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MaxExclusive</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MaxInclusive</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MaxLength</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MinExclusive</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MinInclusive</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::MinLength</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Pattern</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Schema</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Schema::Builtin</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::SimpleType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::TotalDigits</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Attribute</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::AttributeSet</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::ENTITY</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::ID</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::IDREF</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::IDREFS</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::NCName</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::NMTOKEN</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::NMTOKENS</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::NOTATION</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::Name</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::QName</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::anySimpleType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::anyType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::anyURI</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::base64Binary</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::boolean</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::byte</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::date</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::dateTime</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::decimal</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::double</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::duration</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::float</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::gDay</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::gMonth</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::gMonthDay</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::gYear</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::gYearMonth</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::hexBinary</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::int</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::integer</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::language</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::list</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::long</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::negativeInteger</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::nonNegativeInteger</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::nonPositiveInteger</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::normalizedString</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::positiveInteger</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::short</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::string</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::time</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::token</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::unsignedByte</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::unsignedInt</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::unsignedLong</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Builtin::unsignedShort</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::ComplexType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::Element</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::Typelib::SimpleType</remote-id>
+ <remote-id type="cpan-module">SOAP::WSDL::XSD::WhiteSpace</remote-id>
+ </upstream>
+</pkgmetadata>