summaryrefslogtreecommitdiff
path: root/dev-perl/SOAP-Lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/SOAP-Lite
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest5
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild50
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml99
3 files changed, 154 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
new file mode 100644
index 000000000000..942ce694a769
--- /dev/null
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -0,0 +1,5 @@
+DIST SOAP-Lite-1.19.tar.gz 271044 SHA256 f56d8d2ea51832a317020f635e584e38515b6d60526fd722aca360b367f23729 SHA512 530deba9011075b65e8eae4c64cac62c374cd17823e1d23b8383af2bc28075aa1e68809eb8b09a98b44c29cbd7398e6d24ffc9808badc39453f6b9e87a2e1a1d WHIRLPOOL c800649d2652835c709bd102e0468054794deab25e5dce68da9b6a28236b0580073828802d7b769baf276d3d4c6f98c6e545214a2378608b4ff81a3a67c7fa27
+EBUILD SOAP-Lite-1.190.0.ebuild 1044 SHA256 1bfd93a25b4615580d473c9adfef891fa3732f3488e13b81392b3dc42c9778cf SHA512 7b51376713d6adde3cd6c852cff5080c8f657a3ab2cc707bed6dd9102d2bb65abd2b73adad69645bb1dafe1a607e82a09ca12fb71bf3a7dab9a066737b26119e WHIRLPOOL 2d6e49a4c7bfbea5d6cd854c92390d700dd62eb75876d8a76b30409040bde7f814b4d32c382cddf15c565f020947d669022bac8f7c963ed1e90fc75f171c0f7b
+MISC ChangeLog 3160 SHA256 bfecbc6f527b12d050d12bc64b0b87aaa26b39d59eaf209eb5f2e61e65d7f6b1 SHA512 6eabb973aaea0a6122eee724b957caf3a61fc296e98f39051104ba441019cbc3f81ceeb56f3b687bb701e37135549e9da818376e39415e3053e1948f0ff5c053 WHIRLPOOL 82fc068700d9c9d31db6635c2145bf4e27896a7b126ab810eb0a0c6f5e7cb966d86cf7d929cb9aca7160b039093f1f0e53f36a5ff3e5fac1153733baf5750479
+MISC ChangeLog-2015 12293 SHA256 6ff6c8c4b3d8f240d145fea9bc93c51de57daafe1c23a36884ab93303482c4c6 SHA512 0fe46afa1018a2f74681c9d762d327a78086ca1cee3585ccdd82f879486bd2dc5ae5e256e9175a3d2b2ba871def142dc7313445ea9d8822a062c79f2e7ac99e6 WHIRLPOOL 90ffcffa637a9d4572566f253050549ee1f6fad1f77afff577b675700323fc1da63ccb08e36050a52207b755b811ee711626204471b7a18b34fb3ad68ad4a0eb
+MISC metadata.xml 6095 SHA256 6f43ed7439ee9ab72c52f1530c79a4aab150aff0e8e40afcc9bb8772ca2dcf58 SHA512 d6292dd744f83651e56ff407e231faacd80fc3c9b6521ba5e7108e0adf3d91dc036969848609237465eb78b16818be971580f0e4a4367b9f01dbe584790fe903 WHIRLPOOL e2e004bb12b8b8a3b07e1a4a569e58c497155fe4ab0de349fab76de6f275429d3597451365fb71a10908f22cc4a9c95b0d1cf73945bee5189e8fdf9652f9280e
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild
new file mode 100644
index 000000000000..6ba5009df024
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.19
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ dev-perl/XML-Parser-Lite
+ )
+"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
new file mode 100644
index 000000000000..334ddc70dd93
--- /dev/null
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -0,0 +1,99 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">SOAP-Lite</remote-id>
+ <remote-id type="cpan-module">Apache::SOAP</remote-id>
+ <remote-id type="cpan-module">Apache::XMLRPC::Lite</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol</remote-id>
+ <remote-id type="cpan-module">My::PingPong</remote-id>
+ <remote-id type="cpan-module">SOAP</remote-id>
+ <remote-id type="cpan-module">SOAP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Cloneable</remote-id>
+ <remote-id type="cpan-module">SOAP::Constants</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Fault</remote-id>
+ <remote-id type="cpan-module">SOAP::Header</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::COM</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema1999</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema2001</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_1</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_2</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Parser</remote-id>
+ <remote-id type="cpan-module">SOAP::SOM</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::WSDL</remote-id>
+ <remote-id type="cpan-module">SOAP::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Object</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Parameters</remote-id>
+ <remote-id type="cpan-module">SOAP::Test</remote-id>
+ <remote-id type="cpan-module">SOAP::Test::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Trace</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Apache</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::CGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Daemon</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::FCGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema1999::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema2001::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchemaApacheSOAP::Deserializer</remote-id>
+ <remote-id type="cpan-module">UDDI::Constants</remote-id>
+ <remote-id type="cpan-module">UDDI::Data</remote-id>
+ <remote-id type="cpan-module">UDDI::Deserializer</remote-id>
+ <remote-id type="cpan-module">UDDI::Lite</remote-id>
+ <remote-id type="cpan-module">UDDI::SOM</remote-id>
+ <remote-id type="cpan-module">UDDI::Serializer</remote-id>
+ <remote-id type="cpan-module">XML::Parser::Lite</remote-id>
+ <remote-id type="cpan-module">XMLRPC</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Constants</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Data</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Deserializer</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Lite</remote-id>
+ <remote-id type="cpan-module">XMLRPC::SOM</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Serializer</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Server::Parameters</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Test</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Test::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Apache</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::CGI</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Daemon</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::POP3</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::TCP</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::TCP::Server</remote-id>
+ </upstream>
+</pkgmetadata>