summaryrefslogtreecommitdiff
path: root/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild')
-rw-r--r--dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
new file mode 100644
index 000000000000..ac3a771364f1
--- /dev/null
+++ b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_P="${P}ii"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Perl library for parsing the output of nsgmls"
+HOMEPAGE="http://search.cpan.org/author/DMEGG/SGMLSpm-1.03ii/"
+SRC_URI="mirror://cpan/authors/id/D/DM/DMEGG/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile.PL "${S}"/Makefile.PL || die
+ epatch "${FILESDIR}"/sgmlspl.patch
+ mv sgmlspl{.pl,} || die
+}