summaryrefslogtreecommitdiff
path: root/dev-perl/SDL
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-perl/SDL
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/SDL')
-rw-r--r--dev-perl/SDL/Manifest4
-rw-r--r--dev-perl/SDL/SDL-2.546.ebuild41
-rw-r--r--dev-perl/SDL/files/SDL-2.546-pointer.patch29
-rw-r--r--dev-perl/SDL/metadata.xml97
4 files changed, 0 insertions, 171 deletions
diff --git a/dev-perl/SDL/Manifest b/dev-perl/SDL/Manifest
deleted file mode 100644
index e99c678562bd..000000000000
--- a/dev-perl/SDL/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX SDL-2.546-pointer.patch 671 BLAKE2B 188280d823e6cffea2e7d33ede63ecb172a8a272aea98272df75a75ee2cb848ca11426912bcdf90cc5cbe61ef21bb86f37803b50f7907ee9903f6173b3253094 SHA512 25a03721a4ffe64b85512fd896cef2a08faf3284ffd2f9a93fe578f7df0e96bc40952a85e39f4023f38fbb664cd7435e5d5587a7d861e884a616835e7eaecec0
-DIST SDL-2.546.tar.gz 2487053 BLAKE2B c0856c844fd94338f7fe9cd1a20f7e7889cf73ac0c4018bca55b4fc630555b344cebe5158db5fb369ae6cbdaa5471a6681aadd71b788bee044fb367b0b12f9aa SHA512 7f7015c90a277b91951a2357bcdf7c3f2f930270d211657c903240ed4529f408c200337ca79e4971eb3912da28ebf1e950053ce4d763c2599c701444c618c71a
-EBUILD SDL-2.546.ebuild 977 BLAKE2B ad97ca34520efe47acaf1c0401474bb44e5989167290de7f3ca8ca7115cb7d8f67a1681416e80bcd57f97a1ff43690d99900a067e6f857039f95bb49c68fd27c SHA512 48633571c7d2b04ca0bbc97ba0f23ca80bf76eab662307f979821c70f319968a6b638e8d59531947836806204a85cbbfb6147dfa286366a604d5d0944e635e63
-MISC metadata.xml 5479 BLAKE2B a41e0c2886b7cc50265b5de20e8194f30d2b187ebbacd3c3bceaa22441f973746b11ca871ead26dbbe35ede9c52727ee6d5a1d0a48604d8df7e9452a84065be6 SHA512 a26caa4c5f2685ea3dc2134f66652740622ac54d6b71567ed9425494300caccfcbe9c969e215dcd07033792c7e30e08426c3adbc6091c0ba4354e08db14b2827
diff --git a/dev-perl/SDL/SDL-2.546.ebuild b/dev-perl/SDL/SDL-2.546.ebuild
deleted file mode 100644
index 3a4ed38754a6..000000000000
--- a/dev-perl/SDL/SDL-2.546.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-MODULE_AUTHOR=FROGGS
-inherit perl-module
-
-DESCRIPTION="Simple DirectMedia Layer (SDL) bindings for perl"
-HOMEPAGE="http://sdl.perl.org/ http://search.cpan.org/dist/SDL/ https://github.com/PerlGameDev/SDL"
-
-LICENSE="GPL-2 OFL-1.1"
-SLOT="0"
-KEYWORDS="amd64 hppa x86"
-IUSE=""
-
-RDEPEND=">=dev-perl/Alien-SDL-1.434
- dev-perl/Capture-Tiny
- dev-perl/File-ShareDir
- dev-perl/Test-Most
- dev-perl/Tie-Simple
- media-libs/libpng:0
- media-libs/libsdl
- media-libs/sdl-gfx
- media-libs/sdl-image
- media-libs/sdl-mixer
- media-libs/sdl-pango
- media-libs/sdl-ttf
- media-libs/smpeg
- media-libs/tiff:0
- virtual/glu
- virtual/jpeg:0
- virtual/opengl
- virtual/perl-ExtUtils-CBuilder
- >=dev-perl/Module-Build-0.400.0
- virtual/perl-Scalar-List-Utils
- virtual/perl-Test-Simple"
-DEPEND=${RDEPEND}
-
-SRC_TEST=parallel
-mydoc='CHANGELOG README TODO'
-PATCHES=( "${FILESDIR}"/${P}-pointer.patch )
diff --git a/dev-perl/SDL/files/SDL-2.546-pointer.patch b/dev-perl/SDL/files/SDL-2.546-pointer.patch
deleted file mode 100644
index b3721ac805e2..000000000000
--- a/dev-perl/SDL/files/SDL-2.546-pointer.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./src/Core/objects/Event.xs.orig 2015-11-02 17:32:54.831820664 -0500
-+++ ./src/Core/objects/Event.xs 2015-11-02 17:33:35.802090936 -0500
-@@ -611,7 +611,7 @@
- char *CLASS = "SDL::JoyHatEvent";
- CODE:
- RETVAL = NULL;
-- if ( &event != NULL )
-+ if ( event )
- RETVAL = &(event->jhat);
- OUTPUT:
- RETVAL
-@@ -683,7 +683,7 @@
- char *CLASS = "SDL::JoyButtonEvent";
- CODE:
- RETVAL = NULL;
-- if ( &event != NULL )
-+ if ( event )
- RETVAL = &(event->jbutton);
- OUTPUT:
- RETVAL
-@@ -755,7 +755,7 @@
- char *CLASS = "SDL::ResizeEvent";
- CODE:
- RETVAL = NULL;
-- if ( &event != NULL )
-+ if ( event )
- RETVAL = &(event->resize);
- OUTPUT:
- RETVAL
diff --git a/dev-perl/SDL/metadata.xml b/dev-perl/SDL/metadata.xml
deleted file mode 100644
index 25cddc5b75b4..000000000000
--- a/dev-perl/SDL/metadata.xml
+++ /dev/null
@@ -1,97 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">SDL</remote-id>
- <remote-id type="cpan-module">Module::Build::SDL</remote-id>
- <remote-id type="cpan-module">SDL</remote-id>
- <remote-id type="cpan-module">SDL::Audio</remote-id>
- <remote-id type="cpan-module">SDL::AudioCVT</remote-id>
- <remote-id type="cpan-module">SDL::AudioSpec</remote-id>
- <remote-id type="cpan-module">SDL::CD</remote-id>
- <remote-id type="cpan-module">SDL::CDROM</remote-id>
- <remote-id type="cpan-module">SDL::CDTrack</remote-id>
- <remote-id type="cpan-module">SDL::Color</remote-id>
- <remote-id type="cpan-module">SDL::Config</remote-id>
- <remote-id type="cpan-module">SDL::Constants</remote-id>
- <remote-id type="cpan-module">SDL::Cursor</remote-id>
- <remote-id type="cpan-module">SDL::Event</remote-id>
- <remote-id type="cpan-module">SDL::Events</remote-id>
- <remote-id type="cpan-module">SDL::GFX</remote-id>
- <remote-id type="cpan-module">SDL::GFX::BlitFunc</remote-id>
- <remote-id type="cpan-module">SDL::GFX::FPSManager</remote-id>
- <remote-id type="cpan-module">SDL::GFX::Framerate</remote-id>
- <remote-id type="cpan-module">SDL::GFX::ImageFilter</remote-id>
- <remote-id type="cpan-module">SDL::GFX::Primitives</remote-id>
- <remote-id type="cpan-module">SDL::GFX::Rotozoom</remote-id>
- <remote-id type="cpan-module">SDL::Image</remote-id>
- <remote-id type="cpan-module">SDL::Internal::Loader</remote-id>
- <remote-id type="cpan-module">SDL::Joystick</remote-id>
- <remote-id type="cpan-module">SDL::Mixer</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::Channels</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::Effects</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::Groups</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::MixChunk</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::MixMusic</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::Music</remote-id>
- <remote-id type="cpan-module">SDL::Mixer::Samples</remote-id>
- <remote-id type="cpan-module">SDL::Mouse</remote-id>
- <remote-id type="cpan-module">SDL::MultiThread</remote-id>
- <remote-id type="cpan-module">SDL::Net</remote-id>
- <remote-id type="cpan-module">SDL::Net::IPaddress</remote-id>
- <remote-id type="cpan-module">SDL::Net::TCP</remote-id>
- <remote-id type="cpan-module">SDL::Net::UDP</remote-id>
- <remote-id type="cpan-module">SDL::Overlay</remote-id>
- <remote-id type="cpan-module">SDL::Palette</remote-id>
- <remote-id type="cpan-module">SDL::Pango</remote-id>
- <remote-id type="cpan-module">SDL::Pango::Context</remote-id>
- <remote-id type="cpan-module">SDL::PixelFormat</remote-id>
- <remote-id type="cpan-module">SDL::RWOps</remote-id>
- <remote-id type="cpan-module">SDL::Rect</remote-id>
- <remote-id type="cpan-module">SDL::SMPEG</remote-id>
- <remote-id type="cpan-module">SDL::SMPEG::Info</remote-id>
- <remote-id type="cpan-module">SDL::Surface</remote-id>
- <remote-id type="cpan-module">SDL::TTF</remote-id>
- <remote-id type="cpan-module">SDL::TTF::Font</remote-id>
- <remote-id type="cpan-module">SDL::TTFont</remote-id>
- <remote-id type="cpan-module">SDL::Time</remote-id>
- <remote-id type="cpan-module">SDL::Tutorial</remote-id>
- <remote-id type="cpan-module">SDL::Tutorial::Animation</remote-id>
- <remote-id type="cpan-module">SDL::Tutorial::LunarLander</remote-id>
- <remote-id type="cpan-module">SDL::Version</remote-id>
- <remote-id type="cpan-module">SDL::Video</remote-id>
- <remote-id type="cpan-module">SDL::VideoInfo</remote-id>
- <remote-id type="cpan-module">SDL_perl</remote-id>
- <remote-id type="cpan-module">SDLx::App</remote-id>
- <remote-id type="cpan-module">SDLx::Controller</remote-id>
- <remote-id type="cpan-module">SDLx::Controller::Interface</remote-id>
- <remote-id type="cpan-module">SDLx::Controller::State</remote-id>
- <remote-id type="cpan-module">SDLx::Controller::Timer</remote-id>
- <remote-id type="cpan-module">SDLx::FPS</remote-id>
- <remote-id type="cpan-module">SDLx::Layer</remote-id>
- <remote-id type="cpan-module">SDLx::LayerManager</remote-id>
- <remote-id type="cpan-module">SDLx::Music</remote-id>
- <remote-id type="cpan-module">SDLx::Music::Data</remote-id>
- <remote-id type="cpan-module">SDLx::Music::Default</remote-id>
- <remote-id type="cpan-module">SDLx::Rect</remote-id>
- <remote-id type="cpan-module">SDLx::SFont</remote-id>
- <remote-id type="cpan-module">SDLx::Sound</remote-id>
- <remote-id type="cpan-module">SDLx::Sprite</remote-id>
- <remote-id type="cpan-module">SDLx::Sprite::Animated</remote-id>
- <remote-id type="cpan-module">SDLx::Surface</remote-id>
- <remote-id type="cpan-module">SDLx::Surface::TiedMatrix</remote-id>
- <remote-id type="cpan-module">SDLx::Surface::TiedMatrixRow</remote-id>
- <remote-id type="cpan-module">SDLx::TTF</remote-id>
- <remote-id type="cpan-module">SDLx::Text</remote-id>
- <remote-id type="cpan-module">SDLx::Validate</remote-id>
- <remote-id type="github">PerlGameDev/SDL</remote-id>
- </upstream>
-</pkgmetadata>