summaryrefslogtreecommitdiff
path: root/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild')
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
new file mode 100644
index 000000000000..47ed029c8108
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJRAY
+DIST_VERSION=0.82
+DIST_EXAMPLES=( "ex/*.xpl" )
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/HTTP-Daemon-6.120.0
+ >=dev-perl/HTTP-Message-6.260.0
+ >=dev-perl/libwww-perl-6.510.0
+ >=virtual/perl-Module-Load-0.360.0
+ >=virtual/perl-Scalar-List-Utils-1.550.0
+ >=dev-perl/XML-Parser-2.460.0
+"
+BEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-7.560.0
+ test? (
+ virtual/perl-IO-Socket-IP
+ >=virtual/perl-Test-Simple-1.302.183
+ )
+"
+
+src_compile() {
+ perl-module_src_compile
+ if use examples; then
+ pushd "${S}/ex" >/dev/null || die "Can't enter ${S}/ex"
+ emake MAKEMETHOD="${S}/blib/script/make_method"
+ popd >/dev/null || die "Can't exit ${S}/ex"
+ fi
+}
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}