summaryrefslogtreecommitdiff
path: root/dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild')
-rw-r--r--dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild b/dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild
new file mode 100644
index 000000000000..582facc1954b
--- /dev/null
+++ b/dev-perl/Probe-Perl/Probe-Perl-0.30.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION="Information about the currently running perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? ( virtual/perl-Test )
+"
+
+src_test() {
+ perl_rm_files t/author-critic.t
+ perl-module_src_test
+}