summaryrefslogtreecommitdiff
path: root/dev-perl/Pod-Elemental
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Pod-Elemental
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Pod-Elemental')
-rw-r--r--dev-perl/Pod-Elemental/Manifest3
-rw-r--r--dev-perl/Pod-Elemental/Pod-Elemental-0.103.4.ebuild39
-rw-r--r--dev-perl/Pod-Elemental/metadata.xml37
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-perl/Pod-Elemental/Manifest b/dev-perl/Pod-Elemental/Manifest
new file mode 100644
index 000000000000..fac0133b55b2
--- /dev/null
+++ b/dev-perl/Pod-Elemental/Manifest
@@ -0,0 +1,3 @@
+DIST Pod-Elemental-0.103004.tar.gz 37215 BLAKE2B d2d8dba34fcc47fbb809674571e6c931dbdd6b30479207f38836b97615b0a76fbbff2b3d78594ba19f9e3c8fbf7c22ebd50d26c28115e53e750ef9814a982491 SHA512 d2cae23f7c4131f74374f72aa52e58840035f2245d290f82594265089400fe669c0c03cf01c5b65688770b1b5eba6f611b60693b245af637711330fe8c617a66
+EBUILD Pod-Elemental-0.103.4.ebuild 797 BLAKE2B 49ba61500d58b7cef4f0d26eeb717acb2b3fe3ad39792bee05a0dff23e30ee41e53c1b640e800b82a0b6617e8d730afcced71ab322694ecd35220aad190aa6af SHA512 8693c4ad54b78d13dd5650ef56e03eb914c88873866de3a02ae1d2095de5877b840c09f864e3abc0d0ff39a554a99cbc3db4b327dd31dbd6708987e7e9e5b811
+MISC metadata.xml 2354 BLAKE2B a2c1c3bf5255b87ce1d1683f0de7574b0fbcd7796e304f938f3490572f0e03f49537560bb0f1ea68cc01c0f4bf06311162ae2d614f9c13cedd3a5af04cddece0 SHA512 bebcdd1f47b091bee8d9cd07843c6e7aa0ca9097cb9cbdf33242e6cf95c49fa686cc08d8c10aa43a95fc55a9de43d52f93160e566be1a4eedc20cc653228c5b5
diff --git a/dev-perl/Pod-Elemental/Pod-Elemental-0.103.4.ebuild b/dev-perl/Pod-Elemental/Pod-Elemental-0.103.4.ebuild
new file mode 100644
index 000000000000..9c38e8a35659
--- /dev/null
+++ b/dev-perl/Pod-Elemental/Pod-Elemental-0.103.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.103004
+inherit perl-module
+
+DESCRIPTION="Work with nestable Pod elements"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Load
+ virtual/perl-Encode
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Mixin-Linewise
+ dev-perl/Moose
+ dev-perl/MooseX-Types
+ >=dev-perl/Pod-Eventual-0.4.0
+ dev-perl/String-RewritePrefix
+ dev-perl/String-Truncate
+ dev-perl/Sub-Exporter
+ dev-perl/Sub-Exporter-ForMethods
+ dev-perl/namespace-autoclean
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ dev-perl/Test-Deep
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/Pod-Elemental/metadata.xml b/dev-perl/Pod-Elemental/metadata.xml
new file mode 100644
index 000000000000..37bb41527068
--- /dev/null
+++ b/dev-perl/Pod-Elemental/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Pod-Elemental</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Autoblank</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Autochomp</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Command</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Document</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Generic::Blank</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Generic::Command</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Generic::Nonpod</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Generic::Text</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Nested</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Command</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Data</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Nonpod</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Ordinary</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Region</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Element::Pod5::Verbatim</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Flat</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Node</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Objectifier</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Paragraph</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Selectors</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Transformer</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Transformer::Gatherer</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Transformer::Nester</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Transformer::Pod5</remote-id>
+ <remote-id type="cpan-module">Pod::Elemental::Types</remote-id>
+ </upstream>
+</pkgmetadata>