summaryrefslogtreecommitdiff
path: root/dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild')
-rw-r--r--dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild b/dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild
new file mode 100644
index 000000000000..07ce73ed9d0a
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DORMANDO
+DIST_VERSION=1.80
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/HTTP-Date
+ dev-perl/Sys-Syscall
+ >=dev-perl/Danga-Socket-1.440.0
+ dev-perl/HTTP-Message
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch"
+ "${FILESDIR}/${PN}-1.80-init-scripts.patch"
+)
+
+PERL_RM_FILES=(
+ # These currently fail for unclear reasons
+ "t/20-put.t"
+ "t/31-realworld.t"
+ "t/32-selector.t"
+ "t/35-reproxy.t"
+ "t/40-ranges.t"
+)
+DIST_TEST="do" # parallel testing broken
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${S}"/gentoo/init.d/perlbal perlbal
+ newconfd "${S}"/gentoo/conf.d/perlbal perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}