summaryrefslogtreecommitdiff
path: root/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
new file mode 100644
index 000000000000..b3ffc3289260
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20171214
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ docinto ''
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+}