summaryrefslogtreecommitdiff
path: root/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild')
-rw-r--r--dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild b/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
new file mode 100644
index 000000000000..a79a4037ff1f
--- /dev/null
+++ b/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OSFAMERON
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="Generate (possibly exuberant) Ctags style tags for Perl sourcecode"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test minimal"
+
+PATCHES=(
+ "${FILESDIR}/vim_noplugin.patch" # https://rt.cpan.org/Ticket/Display.html?id=105899
+ "${FILESDIR}/${PN}-0.32-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-0.32-no-vim-tests.patch"
+)
+PERL_RM_FILES=(
+ "README.pod" # https://rt.cpan.org/Ticket/Display.html?id=113166
+)
+RDEPEND="
+ dev-perl/File-Find-Rule
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Module-Locate
+ dev-perl/Path-Tiny
+ virtual/perl-parent
+ !minimal? (
+ dev-perl/PPI
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ dev-perl/Capture-Tiny
+ dev-perl/Test-Exception
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.420.0
+ !minimal? (
+ app-editors/vim[perl]
+ )
+ )
+"