summaryrefslogtreecommitdiff
path: root/dev-perl/Path-Class
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Path-Class
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Path-Class')
-rw-r--r--dev-perl/Path-Class/Manifest5
-rw-r--r--dev-perl/Path-Class/Path-Class-0.360.0.ebuild38
-rw-r--r--dev-perl/Path-Class/Path-Class-0.370.0.ebuild38
-rw-r--r--dev-perl/Path-Class/metadata.xml15
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-perl/Path-Class/Manifest b/dev-perl/Path-Class/Manifest
new file mode 100644
index 000000000000..be66ba23fd72
--- /dev/null
+++ b/dev-perl/Path-Class/Manifest
@@ -0,0 +1,5 @@
+DIST Path-Class-0.36.tar.gz 37033 BLAKE2B 5ec7833a334da957e928ecbe3b2dafbc12f63c51959af3ce89208ce54f0d7c1ca9cc6c76fb391c871bab98574f4dd17fb50036c45a9c04f28cfe51d1dee0c2e6 SHA512 17ab96c897537a5964efecc3d4883fedc048145f4980d3959cf501a7646f2f7837614da9e379411f7ecb1f8de1bf23615ee57555cc437878470865b3fabc4c2d
+DIST Path-Class-0.37.tar.gz 37473 BLAKE2B 1017de1f17cf0d0f27b07b8f59dfaa4a139e573ff67e7b8c37b522a8c164156943d5281daa5b4daaea87e72fa6b2d0229ede6aafe8f7b093ad0aac1d51d8314b SHA512 044d86f85eebff96bdff8fc11e97884eb4e06d56ecd2d3bfdc045135da6f08c40e644e0e5c1a779a8ef5d6c7c04e159e47721b4e637a92fed7d298b5f798ef83
+EBUILD Path-Class-0.360.0.ebuild 886 BLAKE2B dd51ee485dc07dfaf916dee7c5ecc8488fff715297e57418cab38b6755d951da5513c0b56439843fce9acbb0c6512fca6974aa9693265f312c5b07dd598de7e4 SHA512 496c9730de03dc46caef550247be81d194a673fbf5ec26639b9388a34938240d91dc06ea07258f0d4d8fa935ce376357b98934006c45ce542671032833d2dbf5
+EBUILD Path-Class-0.370.0.ebuild 896 BLAKE2B 3108dce3e813f5308cf1737e6b8ecf1b05af047585981aed77382b5ddd43c0fe32374f0dd70525ad16da068c4d124d82be59c6d5068e43d8e40e3af2f12ae7c8 SHA512 279fc64842388037493f43964aeea28e0bd05ed3a4ae5129b7ff26faf4fe15855597e54b5102250588b58943bb472270a8b3f162124d05a95e89d61393acba17
+MISC metadata.xml 585 BLAKE2B bab95c7547e43f88f7600192f911af16c29bf7356a62b64d94058dd4f8d1f44de76ad65490c05db359cf2f21ce86b788e92ea88dd83fe738b0ff795c4b05e5f5 SHA512 305513019b4556f6d88bd4e6948d9def1f95bad924a3c347a9b8b9d4912cfd24dc1d9ea1cfe499e6660d45b7dbccb8cefa66d3f83526556b7f0d1b7ddc5cdb83
diff --git a/dev-perl/Path-Class/Path-Class-0.360.0.ebuild b/dev-perl/Path-Class/Path-Class-0.360.0.ebuild
new file mode 100644
index 000000000000..214473c16950
--- /dev/null
+++ b/dev-perl/Path-Class/Path-Class-0.360.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.36
+inherit perl-module
+
+DESCRIPTION="Cross-platform path specification manipulation"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-3.260.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Perl-OSType
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/author-critic.t"
+ perl-module_src_test
+}
diff --git a/dev-perl/Path-Class/Path-Class-0.370.0.ebuild b/dev-perl/Path-Class/Path-Class-0.370.0.ebuild
new file mode 100644
index 000000000000..8a2b2d821d42
--- /dev/null
+++ b/dev-perl/Path-Class/Path-Class-0.370.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Cross-platform path specification manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-3.260.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Perl-OSType
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/author-critic.t"
+ perl-module_src_test
+}
diff --git a/dev-perl/Path-Class/metadata.xml b/dev-perl/Path-Class/metadata.xml
new file mode 100644
index 000000000000..d659152eb9bb
--- /dev/null
+++ b/dev-perl/Path-Class/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Path-Class</remote-id>
+ <remote-id type="cpan-module">Path::Class</remote-id>
+ <remote-id type="cpan-module">Path::Class::Dir</remote-id>
+ <remote-id type="cpan-module">Path::Class::Entity</remote-id>
+ <remote-id type="cpan-module">Path::Class::File</remote-id>
+ </upstream>
+</pkgmetadata>