summaryrefslogtreecommitdiff
path: root/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild')
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
new file mode 100644
index 000000000000..46be8ddd25e3
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SZABGAB
+DIST_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-XSAccessor-1.20.0
+ >=dev-perl/PPI-1.215.0
+ >=dev-perl/Try-Tiny-0.110.0
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Most
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-NoWarnings
+ dev-perl/CPAN-Changes
+ )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}