summaryrefslogtreecommitdiff
path: root/dev-perl/POSIX-strftime-Compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /dev-perl/POSIX-strftime-Compiler
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'dev-perl/POSIX-strftime-Compiler')
-rw-r--r--dev-perl/POSIX-strftime-Compiler/Manifest4
-rw-r--r--dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild31
-rw-r--r--dev-perl/POSIX-strftime-Compiler/metadata.xml4
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-perl/POSIX-strftime-Compiler/Manifest b/dev-perl/POSIX-strftime-Compiler/Manifest
index 3c107b59524d..edea4394be3e 100644
--- a/dev-perl/POSIX-strftime-Compiler/Manifest
+++ b/dev-perl/POSIX-strftime-Compiler/Manifest
@@ -1,3 +1,5 @@
DIST POSIX-strftime-Compiler-0.41.tar.gz 17187 BLAKE2B 541618ba973dceb9431b0c231590310b5cc26743e79fbee12068cef02b8eee959545b2cbe9e7b7affa6da02fb7022d9474025cff25cf8a63d7ead80024b7eddf SHA512 b613de3fb332313318cca8a6c8912b64e9dac702d5681d252dc8eb919c7b102354ad25f60b537cdfa66203e01826b34a5a349a2fac856a6affb40d5f160725fe
+DIST POSIX-strftime-Compiler-0.42.tar.gz 17294 BLAKE2B 3c96c8226b4dd06f449a2a6e56785862e98014e8fb8371709fcc6872ec115cff58fc6aa8c98dd5032488917478448b2137749aa3621d7b446a08c923e99de81e SHA512 0c07f1b8589b067533c65a023dd634a29640cb8992aae8047aa1063affe6b30b95930479829982a30a13b87bc7c9ebf82ca4837726bd29658d85d718164e3c76
EBUILD POSIX-strftime-Compiler-0.410.0.ebuild 795 BLAKE2B aa636a9c56d03de0651fb62b22b460e7e64e5ef76d0764751fde31accc601a6d15e1711bd83b06827d348f3386d4fbcb52ee0a3da484d9574883cd25b6e0dcd4 SHA512 6f33ac82179a1da8105bdea6a4ae43ba5300269442f9cddd766504b4531100e22bf5c31c04daffa17550c648b04d1a6315785272c3e56819a6322c70c0cd01e0
-MISC metadata.xml 257 BLAKE2B 04035438572dc9c398ed29172f6454a150c86d72e6cad7947b0adb3ec8fcc084c68530bca43988c6e1683f4b89d4698796cbe212e9a44b5dfe1908999a8444f0 SHA512 80cde0da56c3ac4023da7b0c17c62eae85139aaefd8ba453dd0c0718da1d40102c57d5beb5b8f984dcbeacad930517347e4d91dd5bd94e973fb81974d078a18e
+EBUILD POSIX-strftime-Compiler-0.420.0.ebuild 659 BLAKE2B 9ff55915ea480ede451f9dc9e273889729065340228457b210615894e829993b472948f772892dc9840d2402b1921ddf53c75bd1c9947dcd3d07ba4abc669bbc SHA512 4921c92df3cf1114928a500fc4a97554d7587ddfb7385bb8c7149f7b1fd6e68f241fa6dba10edf5c07a28b8a102e2dbed5c21eaee3f10ff3026120bfe85c438f
+MISC metadata.xml 419 BLAKE2B bb34ee0557b31bbf216b81d98085d7a30f110bf98176dc21eeba20e0d4fd8e4405ce4e6161bb390afa84d51545f73117623fba09f4ad5575d40807ae5de71f7a SHA512 72e34096d5c2304242723e727a974d2379cbdc482b51af2a417c8ab1ecd07bcad640461f70f94a011f3e05a5f7368a37b853c9eb8deb9a094120b87e09d2ba90
diff --git a/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild
new file mode 100644
index 000000000000..90761177613b
--- /dev/null
+++ b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.42
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="GNU C library compatible strftime for loggers and servers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+# POSIX -> perl
+RDEPEND="
+ !minimal? ( dev-perl/Time-TZOffset )
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Time-Local
+"
+
+# CPAN::Meta::Prereqs -> perl-CPAN-Meta
+DEPEND="
+ >=dev-perl/Module-Build-0.380.0
+ virtual/perl-CPAN-Meta
+ ${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-0.980.0 )
+"
diff --git a/dev-perl/POSIX-strftime-Compiler/metadata.xml b/dev-perl/POSIX-strftime-Compiler/metadata.xml
index 2b9a936fc0a1..0a798428ba18 100644
--- a/dev-perl/POSIX-strftime-Compiler/metadata.xml
+++ b/dev-perl/POSIX-strftime-Compiler/metadata.xml
@@ -5,4 +5,8 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="cpan">POSIX-strftime-Compiler</remote-id>
+ <remote-id type="cpan-module">POSIX::strftime::Compiler</remote-id>
+ </upstream>
</pkgmetadata>