summaryrefslogtreecommitdiff
path: root/dev-perl/ORLite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/ORLite
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/ORLite')
-rw-r--r--dev-perl/ORLite/Manifest6
-rw-r--r--dev-perl/ORLite/ORLite-1.980.0-r1.ebuild34
-rw-r--r--dev-perl/ORLite/files/ORLite-1.98-dot-in-inc.patch394
-rw-r--r--dev-perl/ORLite/metadata.xml12
4 files changed, 446 insertions, 0 deletions
diff --git a/dev-perl/ORLite/Manifest b/dev-perl/ORLite/Manifest
new file mode 100644
index 000000000000..0e2a7b1ae35c
--- /dev/null
+++ b/dev-perl/ORLite/Manifest
@@ -0,0 +1,6 @@
+AUX ORLite-1.98-dot-in-inc.patch 9606 SHA256 52d5fd90eeec61b57021aef98a47f85be92282b2f1b8564ebfdbd5f5ec4b1d87 SHA512 947130481b5826582b103c8c26100a2c3c78c8615c1349e77509acdd46bd6dbc0a6be57e276208c6100e182bc54a1ecb4c1eb5d06abea6d875561f6b0b3994c2 WHIRLPOOL 2443b60d64ade0f38e99eb8a5b5db3e56720bc217afc74ea6f2cafc9ce4f6e28a305db829758850000238dc46ed0313d48d0a61401b0f1379602dfb183d232e2
+DIST ORLite-1.98.tar.gz 67402 SHA256 79e9ef07dee7feb7cafdea1a9c0432e12587fc350707a6bc72fd29502b87d021 SHA512 1cc2f8352efe2867806611746d78cf8aa9788e2f38eeb9231ab7b4168a3befeecdb1773360a13578758f9172d08f55261e952698a3e8c5a5b8ad5e63939349f9 WHIRLPOOL a7df57eb0e9dd3da1603d7aac0596b1134ea7bb7cce8cb3b688c12819bbe99364b9d7ce65f797e9ba3b7554b30581f00ee02b3752304de33ce2e983af7dbca39
+EBUILD ORLite-1.980.0-r1.ebuild 653 SHA256 61195e74750d2160cd5bb377fba2ee71abda67f92e7d36f69c785b3c914ff61d SHA512 93ccb64ecea6e5c5cbd9b1b2bae2c2f6fac461bdf16f9ee01f4fca9c6f2e8c5894ebfb2174e655c09d6aee16d9898619d17fa1bc8038e6f073a48dad9c9b52e2 WHIRLPOOL f391669953512314a9cbbf1b72b0099a4a7d13abcdde1a98d190d8c3c9ef8974965c472b73dffe88d7f6326fefd6998c02a87bf21cee0b0cfd82cbce6d5d4505
+MISC ChangeLog 2671 SHA256 782fbbd84d690a525a053cc10d688025fce11737f396158b13d917373579088c SHA512 3bd920bcb91605f1791e6eacb102c2f9806037d4c13993705b4ac327d85944a33cf4f1ccd94c6f148739dbf6a06729725963e20e9ec52981fec04d30da797e07 WHIRLPOOL bea659297744d7d6704c1798ad490c15681abf1834640099c97eaef5346064a0f0dff069bd80af1cefe80e9d7a873d618b20606778c3161408f3e94f5ed143aa
+MISC ChangeLog-2015 4899 SHA256 413447dc4952d7de82908f857ed602a7fd17fbf6477e00c79d691b3fa8e47955 SHA512 f75abc3061f2c11160872131ef5ab8b05233393eec87d3e85b7344666c970ddb0f526966c4163d9ee3152ba6d05ad15efd8c3d4e3f433b684533cd2b28d68a59 WHIRLPOOL 2dbabb81b1f7d468619d5593e80af4344386c75de220f2b78a7bd1136ea1b1ca421d9c22752f451b7f05c28cf207eb9ad0c50ebe29cbb78299d2b5bcb0cf7698
+MISC metadata.xml 383 SHA256 b6fcd8e1f67cb42a9c827411520e03a4cce75962b1ffb586a0229afe9fdc6445 SHA512 d0cafda7818648e86c4d3a9953e040bc64dff73f22563805d243b0ed4a4477c6fb3f70139779a5d0370d0160eae88f2d2692db1d0f7e180a96e02082761c58fa WHIRLPOOL a909249964e519a70de7e452408f6aeb8ee2f53c6c0e456d45f019e33a136854016dda7b03368b9541b1d08dceb3ed1015c5706fbd4f269176ee867934ba830b
diff --git a/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild b/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild
new file mode 100644
index 000000000000..f383462f6fa9
--- /dev/null
+++ b/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.98
+inherit perl-module
+
+DESCRIPTION="Extremely light weight SQLite-specific ORM"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=virtual/perl-File-Path-2.08
+ >=virtual/perl-File-Temp-0.20
+ >=dev-perl/Params-Util-1
+ >=dev-perl/DBI-1.607
+ >=dev-perl/DBD-SQLite-1.27
+ >=dev-perl/File-Remove-1.40
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ >=dev-perl/Test-Script-1.06
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+PATCHES=( "${FILESDIR}/${PN}-1.98-dot-in-inc.patch" )
+DIST_TEST="do" # Parallel tests broken
diff --git a/dev-perl/ORLite/files/ORLite-1.98-dot-in-inc.patch b/dev-perl/ORLite/files/ORLite-1.98-dot-in-inc.patch
new file mode 100644
index 000000000000..e08be4560ca0
--- /dev/null
+++ b/dev-perl/ORLite/files/ORLite-1.98-dot-in-inc.patch
@@ -0,0 +1,394 @@
+From 8dd424a2c96200a491bea293d38898f9703dfd56 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 7 Jul 2017 11:02:30 +1200
+Subject: [PATCH] Fix tests failing without '.' in @INC
+
+Note: t/22_overlay.t seems to have some magical behaviour
+where previously it loaded t/lib/TableOne.pm by *implication* during
+ORLite construction.
+
+The test code for this needs to be slightly augmented to retain
+traditional semantics without radially overhauling the test code.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=122383
+---
+ Makefile.PL | 1 +
+ t/01_compile.t | 2 +-
+ t/02_basics.t | 2 +-
+ t/03_fk.t | 2 +-
+ t/04_readonly.t | 2 +-
+ t/05_notables.t | 2 +-
+ t/06_create.t | 2 +-
+ t/07_pk.t | 2 +-
+ t/08_prune.t | 2 +-
+ t/09_badfile.t | 2 +-
+ t/10_cleanup.t | 2 +-
+ t/11_cleanup.t | 2 +-
+ t/12_xs.t | 2 +-
+ t/13_array_basics.t | 2 +-
+ t/14_array_fk.t | 2 +-
+ t/15_array_xs.t | 2 +-
+ t/16_array_create.t | 2 +-
+ t/17_cache.t | 2 +-
+ t/18_update.t | 2 +-
+ t/19_view.t | 2 +-
+ t/20_shim.t | 2 +-
+ t/21_normalize.t | 2 +-
+ t/22_overlay.t | 10 ++++++----
+ t/23_unicode.t | 2 +-
+ t/24_rowid.t | 2 +-
+ t/25_blob.t | 2 +-
+ 26 files changed, 31 insertions(+), 28 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 5a4610a..c762072 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install::DSL 1.06;
+
+ all_from lib/ORLite.pm
+diff --git a/t/01_compile.t b/t/01_compile.t
+index 9e8d053..05b1cd0 100644
+--- a/t/01_compile.t
++++ b/t/01_compile.t
+@@ -10,7 +10,7 @@ BEGIN {
+ use Test::More tests => 3;
+
+ require_ok( 'ORLite' );
+-require_ok( 't::lib::Test' );
++require_ok( './t/lib/Test.pm' );
+
+ is(
+ $ORLite::VERSION,
+diff --git a/t/02_basics.t b/t/02_basics.t
+index 448e256..3f9df0d 100644
+--- a/t/02_basics.t
++++ b/t/02_basics.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 74;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ SCOPE: {
+ # Test file
+diff --git a/t/03_fk.t b/t/03_fk.t
+index 7f5db26..88d57e1 100644
+--- a/t/03_fk.t
++++ b/t/03_fk.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 5;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/04_readonly.t b/t/04_readonly.t
+index c13fcd7..b918fc2 100644
+--- a/t/04_readonly.t
++++ b/t/04_readonly.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 13;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ SCOPE: {
+ # Test file
+diff --git a/t/05_notables.t b/t/05_notables.t
+index a5772c5..5f0d867 100644
+--- a/t/05_notables.t
++++ b/t/05_notables.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 5;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ SCOPE: {
+ # Test file
+diff --git a/t/06_create.t b/t/06_create.t
+index 9a2735a..cc2ba57 100644
+--- a/t/06_create.t
++++ b/t/06_create.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 25;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/07_pk.t b/t/07_pk.t
+index 49c85ad..072ffa3 100644
+--- a/t/07_pk.t
++++ b/t/07_pk.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 6;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+ #####################################################################
+diff --git a/t/08_prune.t b/t/08_prune.t
+index 9ea2ca8..ac95366 100644
+--- a/t/08_prune.t
++++ b/t/08_prune.t
+@@ -12,7 +12,7 @@ BEGIN {
+ use Test::More tests => 7;
+ use Test::Script;
+ use File::Remove;
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ # Where the test file will be
+ my $file = test_db();
+diff --git a/t/09_badfile.t b/t/09_badfile.t
+index 4d3445e..cf43ff4 100644
+--- a/t/09_badfile.t
++++ b/t/09_badfile.t
+@@ -11,7 +11,7 @@ BEGIN {
+ use Test::More tests => 2;
+ use Test::Script;
+ use File::Remove;
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ # Where the test file will be
+ my $file = test_db();
+diff --git a/t/10_cleanup.t b/t/10_cleanup.t
+index 75a3cf3..9683624 100644
+--- a/t/10_cleanup.t
++++ b/t/10_cleanup.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 2;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+ #####################################################################
+diff --git a/t/11_cleanup.t b/t/11_cleanup.t
+index 7ba7af1..6e95ff7 100644
+--- a/t/11_cleanup.t
++++ b/t/11_cleanup.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 4;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+ #####################################################################
+diff --git a/t/12_xs.t b/t/12_xs.t
+index 151b2ed..6a26730 100644
+--- a/t/12_xs.t
++++ b/t/12_xs.t
+@@ -19,7 +19,7 @@ BEGIN {
+ }
+ }
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/13_array_basics.t b/t/13_array_basics.t
+index 71a3d54..62fb167 100644
+--- a/t/13_array_basics.t
++++ b/t/13_array_basics.t
+@@ -10,7 +10,7 @@ BEGIN {
+
+ use Test::More tests => 71;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ SCOPE: {
+ # Test file
+diff --git a/t/14_array_fk.t b/t/14_array_fk.t
+index fc898b0..842b33c 100644
+--- a/t/14_array_fk.t
++++ b/t/14_array_fk.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 5;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/15_array_xs.t b/t/15_array_xs.t
+index 97402c0..06d5b1b 100644
+--- a/t/15_array_xs.t
++++ b/t/15_array_xs.t
+@@ -19,7 +19,7 @@ BEGIN {
+ }
+ }
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/16_array_create.t b/t/16_array_create.t
+index 817c72a..3123c0c 100644
+--- a/t/16_array_create.t
++++ b/t/16_array_create.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 25;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/17_cache.t b/t/17_cache.t
+index 5a64066..8472373 100644
+--- a/t/17_cache.t
++++ b/t/17_cache.t
+@@ -11,7 +11,7 @@ BEGIN {
+ use Test::More tests => 9;
+ use File::Spec::Functions ':ALL';
+ use File::Remove 'clear';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ # Where will the cache file be written to
+ my $orlite_version = $t::lib::Test::VERSION;
+diff --git a/t/18_update.t b/t/18_update.t
+index 840f9c0..bf3eed6 100644
+--- a/t/18_update.t
++++ b/t/18_update.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 10;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/19_view.t b/t/19_view.t
+index d893b59..120d9e1 100644
+--- a/t/19_view.t
++++ b/t/19_view.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 81;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ # Set up again
+ my $file = test_db();
+diff --git a/t/20_shim.t b/t/20_shim.t
+index 7f47634..3868225 100644
+--- a/t/20_shim.t
++++ b/t/20_shim.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 12;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/21_normalize.t b/t/21_normalize.t
+index 2a6aa83..f703c64 100644
+--- a/t/21_normalize.t
++++ b/t/21_normalize.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 78;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ SCOPE: {
+ # Test file
+diff --git a/t/22_overlay.t b/t/22_overlay.t
+index fca2faa..5848d61 100644
+--- a/t/22_overlay.t
++++ b/t/22_overlay.t
+@@ -9,7 +9,7 @@ BEGIN {
+
+ use Test::More tests => 7;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+@@ -30,9 +30,11 @@ eval <<"END_PERL"; die $@ if $@;
+ package t::lib;
+
+ use strict;
+-use ORLite {
+- file => '$file',
+-};
++BEGIN {
++ require ORLite;
++ local \@INC=(\@INC, '.');
++ ORLite->import({ file => '$file' });
++}
+
+ 1;
+ END_PERL
+diff --git a/t/23_unicode.t b/t/23_unicode.t
+index a63d50f..b2be363 100644
+--- a/t/23_unicode.t
++++ b/t/23_unicode.t
+@@ -17,7 +17,7 @@ BEGIN {
+
+ use utf8;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+diff --git a/t/24_rowid.t b/t/24_rowid.t
+index a5527f5..5104437 100644
+--- a/t/24_rowid.t
++++ b/t/24_rowid.t
+@@ -11,7 +11,7 @@ BEGIN {
+
+ use Test::More tests => 51;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+ # Set up the database
+ my $file = test_db();
+diff --git a/t/25_blob.t b/t/25_blob.t
+index 75aa607..b0bdf06 100644
+--- a/t/25_blob.t
++++ b/t/25_blob.t
+@@ -9,7 +9,7 @@ BEGIN {
+ }
+ use Test::More;
+ use File::Spec::Functions ':ALL';
+-use t::lib::Test;
++BEGIN { require "./t/lib/Test.pm"; t::lib::Test->import() }
+
+
+
+--
+2.13.1
+
diff --git a/dev-perl/ORLite/metadata.xml b/dev-perl/ORLite/metadata.xml
new file mode 100644
index 000000000000..e2990d91c423
--- /dev/null
+++ b/dev-perl/ORLite/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">ORLite</remote-id>
+ <remote-id type="cpan-module">ORLite</remote-id>
+ </upstream>
+</pkgmetadata>