summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Whois-IP
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
commit0fb71e0215ed52863e462cccef73c01aff44d43d (patch)
tree428fc3fa92f9c69ed02878e9b6151a9fb810e651 /dev-perl/Net-Whois-IP
parent9bd54251864651f49e673a08aec9ef79cfe08f04 (diff)
gentoo resync : 18.12.2017
Diffstat (limited to 'dev-perl/Net-Whois-IP')
-rw-r--r--dev-perl/Net-Whois-IP/Manifest3
-rw-r--r--dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild51
-rw-r--r--dev-perl/Net-Whois-IP/metadata.xml4
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-perl/Net-Whois-IP/Manifest b/dev-perl/Net-Whois-IP/Manifest
index 923e708afc49..f3faccfdc33b 100644
--- a/dev-perl/Net-Whois-IP/Manifest
+++ b/dev-perl/Net-Whois-IP/Manifest
@@ -1,3 +1,4 @@
DIST Net-Whois-IP-1.19.tar.gz 25192 BLAKE2B 41dff899207f548a4a3fae1c011c6d46692ec14a601fc4bebe0f976371ab5a170db64db4e330c706832142a0577bdd57c9261993e9c354877dbe46f44c739f86 SHA512 80d1be9dc6c8e9da74df97524f1a804f6ab64f1e016509944b1ba970c2a508e46cd6d633c6cfc2e9fa5d3fc8240500f81cbc90a27bdeab26cb7b590ba97758ae
+EBUILD Net-Whois-IP-1.190.0-r1.ebuild 1208 BLAKE2B 2a26220d690974ab226e275108658b286cf4da96f1d4025e04da5446d7f6b3881a917e926af31488c20f9a97b37567603a3c2e10267182bcee24e5391158d93e SHA512 dbaa8220a9d1554b8d57ab0708d06b78fbd5101fca04002318f92456631228d668ccf7c6d922a47063be14e8f9323406747282630ce7841608b5bc24b079c71a
EBUILD Net-Whois-IP-1.190.0.ebuild 794 BLAKE2B 94cd1c6e9ff30942fdab50128bcc7909d6e5666631e58dc87b33ea94858c62e8f841e6e789634e34d7d3855cef6ec999b08b0a607c27a6d67f40926acf3c2634 SHA512 088b3b96a608af471e57e9d8ea50c4c014612acc9fee470398a169bc4194ccd4bd83d60f8bed4f9702378d9ad7aca08e3d1841aabc997a5579455401caa3f9fd
-MISC metadata.xml 371 BLAKE2B 8690216719666584fbacbe4c9a1b622de7b0f36a38ee70c320ae2d664fb46e8c27dfa604d92fc71f093128572bbaa3a906bc2b371ca929d0096c1aed73e2f133 SHA512 828b617d47d6cea61dcb4eaec4386c9844f0588d18e0ecd8694611a30265caf9700b2be69396bcd1a4c156236e5e5e1ae51f12d53bc061db22cba62d353637ec
+MISC metadata.xml 511 BLAKE2B 95f9e9610aa9ef5e95ab37f004f7fa0fa841ecaa6d5838b276fa738138bb5ce3169e464f126fd156ce503ce3a5feb1d660b4ae9ede9eca8f01ac253280cc12e2 SHA512 98c89481190eb891b08446f738e696898f9d7ce6ceaa6b852bbbf3d90aafdc5b7c224d75c537f5aae1da8f1c999cae9bcea0fd2f8eb8ac8efe9b1cb00957e122
diff --git a/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild b/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
new file mode 100644
index 000000000000..32f794ca21f1
--- /dev/null
+++ b/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=${PV%0.0}
+DIST_AUTHOR=BSCHMITZ
+inherit perl-module
+
+DESCRIPTION="Perl extension for looking up the whois information for ip addresses"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PERL_RM_FILES=(
+ "test.pl" # gets installed otherwise :(
+)
+RDEPEND="
+ dev-perl/Regexp-IPv6
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ local MODULES=(
+ "Net::Whois::IP ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ # # All tests defined require networking
+ # and all fail.
+ # https://rt.cpan.org/Public/Bug/Display.html?id=110961
+ # local my_test_control
+ # my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ # if ! has network ${my_test_control} ; then
+ # perl_rm_files "t/test1.t" "t/testx.t"
+ # fi
+ # perl-module_src_test
+}
diff --git a/dev-perl/Net-Whois-IP/metadata.xml b/dev-perl/Net-Whois-IP/metadata.xml
index 74081c2bc74c..dffda38316da 100644
--- a/dev-perl/Net-Whois-IP/metadata.xml
+++ b/dev-perl/Net-Whois-IP/metadata.xml
@@ -9,4 +9,8 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="cpan">Net-Whois-IP</remote-id>
+ <remote-id type="cpan-module">Net::Whois::IP</remote-id>
+ </upstream>
</pkgmetadata>