summaryrefslogtreecommitdiff
path: root/dev-perl/Net-PcapUtils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-perl/Net-PcapUtils
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-perl/Net-PcapUtils')
-rw-r--r--dev-perl/Net-PcapUtils/Manifest2
-rw-r--r--dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild26
-rw-r--r--dev-perl/Net-PcapUtils/files/Net-PcapUtils-0.01-testsuite.patch85
3 files changed, 113 insertions, 0 deletions
diff --git a/dev-perl/Net-PcapUtils/Manifest b/dev-perl/Net-PcapUtils/Manifest
index 87aa652daaac..6921b7b60e06 100644
--- a/dev-perl/Net-PcapUtils/Manifest
+++ b/dev-perl/Net-PcapUtils/Manifest
@@ -1,3 +1,5 @@
+AUX Net-PcapUtils-0.01-testsuite.patch 1663 BLAKE2B 83daa118768919aa4f291bdcc0487bab98e015ac6009af16a6469f21ddc8488209295e53ed4fca7feedb51d9fd11ab840ea624f191ccc3f170d40397e054e70d SHA512 4cc5459adbfe378dcea6ad557244e1707d7c670e3ae4ef7d0030f07b46fbf337d7df8a70e7aa31e3ca8963745011a3a14ff1e41671a26e0417cd96a8e92bef6d
DIST Net-PcapUtils-0.01.tar.gz 4370 BLAKE2B 475e55aea7efc4c7e603f826a081df05f9f5025a9de4f88354b9b1231cbbccc613440aea44fe7f6540ff6099a91002d86f015730c6a74557e9991af95f664f3d SHA512 19fa2215f6ee69005c585e7d381738c6a5fdbf6b09267a38014b7d4bd0f604ba21a7b16dd8d4aba20b8e290044c3a6ab1fc6f29070a666d7785a690bac228708
EBUILD Net-PcapUtils-0.10.0-r1.ebuild 333 BLAKE2B 581740d2feb483ab289f921b2a50fbf646d36f65fe57a9a118c7ad22d4638d717336bbe61081fe22841542514e8741e35488a1f1cbb0d47156fb203d43ef836a SHA512 5d95bb68933fbf90a6f683006c600548e1af2f99ff6513597279d1cb90b2df75000a270b66c6cd28039a557747041f3f709e01dc289cca2c05c01e2dea9c1f89
+EBUILD Net-PcapUtils-0.10.0-r2.ebuild 590 BLAKE2B 0bb014613bc79ee777d783a8b92001c40b1be4d53430aea996ec3d9db3fc1b18774f37888c151dfbd3f71fa35104275990539212c1699063e3a98cc1091dfda5 SHA512 c53cf7768e4ab238cc416cc4c53d605be5cc80766f4d0e44246e21b2545d1ace4941054965a231921bd6afd46905111dcb301a87db4812199bc5553fd10c14ed
MISC metadata.xml 398 BLAKE2B d181cced3de6be4951361621d643bdc8c1855fadb46c6d3d93e0eadf98f7d3baa44f95b7d778312bfd256d0b44fc5bf561353cf361cc235cef2d719c05ac2bd6 SHA512 5fd32cd69efc82ee5acc704b57f0a949db7379b2b051582ce4fdba51a02344424498b8b3654b792ed770f378cc5e469c3227c2f764967bb269f36c9114f305fe
diff --git a/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild b/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..f6f9f7912ed7
--- /dev/null
+++ b/dev-perl/Net-PcapUtils/Net-PcapUtils-0.10.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMPOTTER
+DIST_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="Utility routines for use with Net::Pcap"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Net-Pcap"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-0.01-testsuite.patch")
+
+src_test() {
+ if [[ $EUID != 0 ]]; then
+ elog "Some tests require root privileges. For details, see:"
+ elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Net-PcapUtils/files/Net-PcapUtils-0.01-testsuite.patch b/dev-perl/Net-PcapUtils/files/Net-PcapUtils-0.01-testsuite.patch
new file mode 100644
index 000000000000..c820e963ed69
--- /dev/null
+++ b/dev-perl/Net-PcapUtils/files/Net-PcapUtils-0.01-testsuite.patch
@@ -0,0 +1,85 @@
+From 943ea70672f52f1d7548723a1ef8f15b6249fdc2 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 14 Dec 2017 19:19:07 +1300
+Subject: Fix test suite to be useful in non-root environments
+
+While also exposing the need to be root to run certain tests
+---
+ t/00-compile.t | 9 +++++++++
+ t/01-loop.t | 6 ++++++
+ t/02-open.t | 7 +++++++
+ t/03-next.t | 7 +++++++
+ 4 files changed, 29 insertions(+)
+ create mode 100644 t/00-compile.t
+
+diff --git a/t/00-compile.t b/t/00-compile.t
+new file mode 100644
+index 0000000..7f2ace4
+--- /dev/null
++++ b/t/00-compile.t
+@@ -0,0 +1,9 @@
++
++use strict;
++use warnings;
++
++print "1..1\n";
++
++local $@;
++eval { require Net::PcapUtils };
++printf "%s load Net::PcapUtils\n", ( $@ ? 'not ok' : 'ok' );
+diff --git a/t/01-loop.t b/t/01-loop.t
+index be7850c..92ad7a6 100644
+--- a/t/01-loop.t
++++ b/t/01-loop.t
+@@ -6,6 +6,12 @@
+ #
+
+ use strict;
++BEGIN {
++ if ( $> != 0 ) {
++ print "1..0 # SKIP This test requires running as root";
++ exit 0;
++ }
++}
+ use ExtUtils::testlib;
+
+ use Net::PcapUtils;
+diff --git a/t/02-open.t b/t/02-open.t
+index 81c8e19..de95e5b 100644
+--- a/t/02-open.t
++++ b/t/02-open.t
+@@ -6,6 +6,13 @@
+ #
+
+ use strict;
++BEGIN {
++ if ( $> != 0 ) {
++ print "1..0 # SKIP This test requires running as root";
++ exit 0;
++ }
++}
++
+ use ExtUtils::testlib;
+
+ use Net::Pcap;
+diff --git a/t/03-next.t b/t/03-next.t
+index b473816..330915e 100644
+--- a/t/03-next.t
++++ b/t/03-next.t
+@@ -6,6 +6,13 @@
+ #
+
+ use strict;
++BEGIN {
++ if ( $> != 0 ) {
++ print "1..0 # SKIP This test requires running as root";
++ exit 0;
++ }
++}
++
+ use ExtUtils::testlib;
+
+ use Net::PcapUtils;
+--
+2.15.1
+