summaryrefslogtreecommitdiff
path: root/dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild')
-rw-r--r--dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild b/dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild
new file mode 100644
index 000000000000..eb0d4416254e
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-1.310.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.31
+DIST_EXAMPLES=( "contrib" "demo" )
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Interface to the Domain Name System"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+PDEPEND="!minimal? ( >=dev-perl/Net-DNS-SEC-1.30.0 )"
+RDEPEND="
+ >=virtual/perl-Carp-1.100.0
+ >=dev-perl/Digest-HMAC-1.30.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=virtual/perl-Digest-SHA-5.230.0
+ >=virtual/perl-Encode-2.260.0
+ >=virtual/perl-Exporter-5.560.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-MIME-Base64-2.130.0
+ >=virtual/perl-Scalar-List-Utils-1.250.0
+ >=virtual/perl-Time-Local-1.190.0
+ >=virtual/perl-IO-Socket-IP-0.380.0
+ >=virtual/perl-IO-1.80.0
+ !minimal? (
+ >=dev-perl/Digest-BubbleBabble-0.10.0
+ >=dev-perl/Net-LibIDN2-1.0.0
+ )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ if ! use test || ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+ fi
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ perl_rm_files t/00-pod.t
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ elog "Network tests disabled without to DIST_TEST_OVERIDE=~network"
+ fi
+ perl-module_src_test
+}