summaryrefslogtreecommitdiff
path: root/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild')
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
new file mode 100644
index 000000000000..bedffda369b2
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.75
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.370.0
+ >=dev-perl/Getopt-Long-Descriptive-0.88.0
+ >=dev-perl/Moose-0.560.0
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Module-Runtime
+ >=dev-perl/Path-Tiny-0.9.0
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Needs
+ dev-perl/Test-Trap
+ >=dev-perl/Test-Warnings-0.9.0
+ virtual/perl-if
+ )
+"