summaryrefslogtreecommitdiff
path: root/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild')
-rw-r--r--dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild b/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
new file mode 100644
index 000000000000..caba919384bf
--- /dev/null
+++ b/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Autoboxed wrappers for Native Perl datatypes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ >=dev-perl/List-MoreUtils-0.70.0
+ >=dev-perl/Moose-0.420.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Syntax-Keyword-Junction
+ >=dev-perl/autobox-2.230.0
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"