summaryrefslogtreecommitdiff
path: root/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild')
-rw-r--r--dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild b/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild
new file mode 100644
index 000000000000..04f4f5a2c504
--- /dev/null
+++ b/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.001009
+inherit perl-module
+
+DESCRIPTION="NativeTrait-like behavior for Moo"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ dev-perl/Class-Method-Modifiers
+ >=dev-perl/Data-Perl-0.2.6
+ dev-perl/Module-Runtime
+ >=dev-perl/Moo-1.3.0
+ dev-perl/Role-Tiny
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/MooX-Types-MooseLike-0.230.0
+ dev-perl/Test-Exception
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"