summaryrefslogtreecommitdiff
path: root/dev-perl/Moo/Moo-2.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-perl/Moo/Moo-2.5.4.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-perl/Moo/Moo-2.5.4.ebuild')
-rw-r--r--dev-perl/Moo/Moo-2.5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Moo/Moo-2.5.4.ebuild b/dev-perl/Moo/Moo-2.5.4.ebuild
new file mode 100644
index 000000000000..9643e6087f85
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.005004
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Role-Tiny-2.2.3
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+ >=dev-perl/Sub-Quote-2.6.6
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"