summaryrefslogtreecommitdiff
path: root/dev-perl/Math-PlanePath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Math-PlanePath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Math-PlanePath')
-rw-r--r--dev-perl/Math-PlanePath/Manifest5
-rw-r--r--dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild35
-rw-r--r--dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild32
-rw-r--r--dev-perl/Math-PlanePath/metadata.xml148
4 files changed, 220 insertions, 0 deletions
diff --git a/dev-perl/Math-PlanePath/Manifest b/dev-perl/Math-PlanePath/Manifest
new file mode 100644
index 000000000000..115d3ce57028
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Manifest
@@ -0,0 +1,5 @@
+DIST Math-PlanePath-123.tar.gz 1284214 BLAKE2B 64f0f7bfe5c02ee7d3f379d1fcb496db91b7e3131399ac5ba83efb127b675b2cb2524ff90d63f0b54da8d769b422ae398645a28c432adcb851dd8db8829b5bac SHA512 5289f674dd62f668e667d69baf52d2f6d8b8fcf4ce6bed1429ef1fb412f2415b474103ca9b6d9c5b876b6926d860f70834e26c68a30b53d2211cbc4c457e2b43
+DIST Math-PlanePath-124.tar.gz 1308595 BLAKE2B e46b50ff23e52076024211ca2967e2e1449eb36dc946eb2214c2fefd582b7abc72098ca5049dd66d9af02333c21ac8f2246b931fe96e0e3594aa800f348114e7 SHA512 24e347134b64642775a5641b7c17d1ba1e15169504023d3f08463fde21dadb41357edfc1d7d07466160cb3a7cd2542e0b1a52a845132223a9473b73b32e31009
+EBUILD Math-PlanePath-123.0.0.ebuild 758 BLAKE2B 2b9aaa023a09374d16bf8180ddaa910cef172ebe5d87d2347b7d249439c03f9609407db7671cec87fce87535f326e24fc8c72d9ad3a10847144ec1229b16f8df SHA512 c02a2193b2a2479453f6eba4db419e0cd8f398cb45e5ff2a966672809e6b9504688af97662d2f1c641a1b65eaac9e604d318664ce6d4a020b074ab858af89502
+EBUILD Math-PlanePath-124.0.0.ebuild 664 BLAKE2B 6f65e2cba724ce1f7d6565e77c91aab6925c3b4afc050218ab43663c4efb3bbd20d150bb2d1d40b566a7250474a6dffd09022ee0f91ddab22d3ee7b96a041653 SHA512 16c5c7d5ff7cc38d40548ef5cd1e6dd6dfffb4b786f5d9e12e97e8a4e6f58d31565cb97ca124c38e0808be0e4fe38f1945c35152a292ef38f75e2b9c3a99e3ed
+MISC metadata.xml 10618 BLAKE2B 190c2f1699b1f0df8b2336c341173eec4209252a0349be806a7d77fdf61a2a939be821ca331b777c4dc599422aac22aaa38766cf4ba2f3323c1afcc51795987c SHA512 4b4d610aae3b1c59bd5faecbd865d0d3a7a5c76f0cda7cc76a1254f0b180d1c89105e7d7f03752ae8005d95265d41430b3a2e0bddf807fc31477cea1ca2b8255
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild
new file mode 100644
index 000000000000..1dd20b1d5d1d
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION="123"
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp test examples"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+ dev-perl/Math-Libm
+ dev-perl/Math-NumSeq
+ >=dev-perl/constant-defer-5.0.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test
+ dev-perl/Math-BigInt-Lite
+ dev-perl/Number-Fraction )"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild
new file mode 100644
index 000000000000..ed1619a58c01
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION=124
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="gmp test"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+ dev-perl/Math-Libm
+ dev-perl/Math-NumSeq
+ >=dev-perl/constant-defer-5.0.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test
+ dev-perl/Data-Float
+ dev-perl/Math-BigInt-Lite
+ dev-perl/Number-Fraction
+ )
+"
diff --git a/dev-perl/Math-PlanePath/metadata.xml b/dev-perl/Math-PlanePath/metadata.xml
new file mode 100644
index 000000000000..b55d0013d79b
--- /dev/null
+++ b/dev-perl/Math-PlanePath/metadata.xml
@@ -0,0 +1,148 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-PlanePath</remote-id>
+ <remote-id type="cpan-module">Math::NumSeq::OEIS::Catalogue::Plugin::PlanePath</remote-id>
+ <remote-id type="cpan-module">Math::NumSeq::PlanePathCoord</remote-id>
+ <remote-id type="cpan-module">Math::NumSeq::PlanePathDelta</remote-id>
+ <remote-id type="cpan-module">Math::NumSeq::PlanePathN</remote-id>
+ <remote-id type="cpan-module">Math::NumSeq::PlanePathTurn</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::AR2W2Curve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::AlternatePaper</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::AlternatePaperMidpoint</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::AnvilSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ArchimedeanChords</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::AztecDiamondRings</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Base::Digits</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Base::Generic</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Base::NSEW</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::BetaOmega</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule190</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule54</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule57</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule::Line</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule::OddSolid</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule::OneTwo</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CellularRule::Two</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CfracDigits</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ChanTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CincoCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Columns</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ComplexMinus</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ComplexPlus</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ComplexRevolving</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CoprimeColumns</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Corner</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CornerReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CretanLabyrinth</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::CubicBase</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DekkingCentres</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DekkingCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DiagonalRationals</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Diagonals</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DiagonalsAlternating</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DiagonalsOctant</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DiamondArms</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DiamondSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DigitGroups</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DivisibleColumns</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DragonCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DragonMidpoint</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::DragonRounded</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::FactorRationals</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::FibonacciWordFractal</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::File</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::FilledRings</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Flowsnake</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::FlowsnakeCentres</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::FractionsTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GcdRationals</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GosperIslands</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GosperReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GosperSide</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GrayCode</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::GreekKeySpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HIndexing</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HeptSpiralSkewed</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HexArms</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HexSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HexSpiralSkewed</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HilbertCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HilbertSides</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HilbertSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Hypot</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::HypotOctant</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ImaginaryBase</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ImaginaryHalf</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KnightSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KochCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KochPeaks</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KochSnowflakes</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KochSquareflakes</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::KochelCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::LCornerReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::LCornerTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::LTiling</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::MPeaks</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::MultipleRings</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::OctagramSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::OneOfEight</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PeanoCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PentSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PentSpiralSkewed</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PixelRings</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PowerArray</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PyramidRows</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PyramidSides</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PyramidSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::PythagoreanTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::QuadricCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::QuadricIslands</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::QuintetCentres</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::QuintetCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::QuintetReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::R5DragonCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::R5DragonMidpoint</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::RationalsTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Rows</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SacksSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SierpinskiArrowhead</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SierpinskiArrowheadCentres</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SierpinskiCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SierpinskiCurveStair</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SierpinskiTriangle</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SquareArms</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SquareReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::SquareSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::Staircase</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::StaircaseAlternating</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TerdragonCurve</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TerdragonMidpoint</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TerdragonRounded</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TheodorusSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ToothpickReplicate</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ToothpickSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ToothpickTree</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ToothpickUpist</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TriangleSpiral</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TriangleSpiralSkewed</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::TriangularHypot</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::UlamWarburton</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::UlamWarburtonQuarter</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::VogelFloret</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::WunderlichMeander</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::WunderlichSerpentine</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::WythoffArray</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::WythoffPreliminaryTriangle</remote-id>
+ <remote-id type="cpan-module">Math::PlanePath::ZOrderCurve</remote-id>
+ </upstream>
+</pkgmetadata>