summaryrefslogtreecommitdiff
path: root/dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild')
-rw-r--r--dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild
new file mode 100644
index 000000000000..0e44b738d0ae
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Math-PlanePath-129.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KRYDE
+DIST_VERSION=129
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+ dev-perl/Math-Libm
+ dev-perl/Math-NumSeq
+ >=dev-perl/constant-defer-5.0.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test
+ dev-perl/Data-Float
+ dev-perl/Math-BigInt-Lite
+ dev-perl/Number-Fraction
+ )
+"