summaryrefslogtreecommitdiff
path: root/dev-perl/Math-ModInt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Math-ModInt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Math-ModInt')
-rw-r--r--dev-perl/Math-ModInt/Manifest3
-rw-r--r--dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild40
-rw-r--r--dev-perl/Math-ModInt/metadata.xml20
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Math-ModInt/Manifest b/dev-perl/Math-ModInt/Manifest
new file mode 100644
index 000000000000..27bd5426b539
--- /dev/null
+++ b/dev-perl/Math-ModInt/Manifest
@@ -0,0 +1,3 @@
+DIST Math-ModInt-0.011.tar.gz 40189 BLAKE2B 2b49dec27c7f67ab0c5005a850df9105d661aaa07fbb4041f9bb79bca621114edd6d541ef62d907e8fdc71d1879fb3eb522af232519cd0500b9d41fb2c1b6938 SHA512 c6a1b90e07dc6a4b620b0db63eaa205dad19ba3c96e8031f93d1c3fca137d5430e3c1e88d3bad9d3f6d64600bee4deb9c13e13fdad410c76f9c10732fd2495e0
+EBUILD Math-ModInt-0.11.0.ebuild 684 BLAKE2B 33b4f82f0ee8bacd69b524ee5c8fee2590c33fddd6712c7efed2d9c4059a757a2ed168e8ed3fd907fc320beaf8884112d113b5c12b944c509f0331ed521dffcb SHA512 45fbcdc0ac5b1739b0a99dcc642610eb8f4ff7d46fbf4672d4df43f87bca52e147e9feb75b7660aada35974f3381d7f273e6c875ff55c4be9ff36d7d4240c2e1
+MISC metadata.xml 937 BLAKE2B ce1dd1e2a2ab5186d6db78091c4d024464390a2261c2dd9c0bab4c00fff92ecb19371c1b083b1516f1b3908825247424563fd995d73afcd3b89581bc225e2133 SHA512 67f8474ca53df04c0f08250b546702f8c6711ba6fef84b6f57e9b9dd8992144ca90b324f5e4ea2df9e370fde518b4e052bfef6978652a6007f76329d45361049
diff --git a/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
new file mode 100644
index 000000000000..5d02b2c3339d
--- /dev/null
+++ b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MHASCH
+DIST_VERSION=0.011
+
+inherit perl-module
+
+DESCRIPTION="modular integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal test"
+
+PERL_RM_FILES=(
+ "t/90_pod.t"
+ "t/91_pod_cover_cp.t"
+ "t/92_consistency.t"
+ "t/93_examples.t"
+ "t/95_versions.t"
+ "t/99_signature.t"
+)
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Math-BigInt-1.991.0
+ !minimal? (
+ dev-perl/Math-BigInt-GMP
+ virtual/perl-Math-BigRat
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Math-ModInt/metadata.xml b/dev-perl/Math-ModInt/metadata.xml
new file mode 100644
index 000000000000..3a6d82a72e69
--- /dev/null
+++ b/dev-perl/Math-ModInt/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-ModInt</remote-id>
+ <remote-id type="cpan-module">Math::ModInt</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::BigInt</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::ChineseRemainder</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::Event</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::Event::Trap</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::GF2</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::GF3</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::Perl</remote-id>
+ <remote-id type="cpan-module">Math::ModInt::Trivial</remote-id>
+ </upstream>
+</pkgmetadata>