summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild')
-rw-r--r--dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
new file mode 100644
index 000000000000..693b54d44fd5
--- /dev/null
+++ b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.22
+DIST_EXAMPLES=("benchmarks/*")
+inherit perl-module
+
+DESCRIPTION="Manipulate 128 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/Math-Int64-0.510.0
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Math-BigInt
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/release-cpan-changes.t"
+ "t/release-pod-syntax.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+)