summaryrefslogtreecommitdiff
path: root/dev-perl/Math-BigInt-Lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Math-BigInt-Lite
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Math-BigInt-Lite')
-rw-r--r--dev-perl/Math-BigInt-Lite/Manifest6
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild38
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild33
-rw-r--r--dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch34
-rw-r--r--dev-perl/Math-BigInt-Lite/metadata.xml12
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Manifest b/dev-perl/Math-BigInt-Lite/Manifest
new file mode 100644
index 000000000000..d4ae8b1744da
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Manifest
@@ -0,0 +1,6 @@
+AUX Math-BigInt-Lite-0.170.0-no-dot-inc.patch 999 BLAKE2B 7ca89a6f9c627c2b6a6914914b711bd079003f99ea891e6732b01e66860e97261239538f82c667d876734261f733b2dd35a3eb9f96e50577dd845303f5974c3b SHA512 0093f2bbab880e0d4290516300a3dba31063b201afa86e527f43aa7d55cdf8e7ef0f9996d41925232438f96644aa094da598dc0bdf00b0a458fdcb0e1da87ca4
+DIST Math-BigInt-Lite-0.14.tar.gz 44517 BLAKE2B 7f84cce7b77fe4e8334ddfc4ac63fa4649acc9f44d3dbbcc21987f7aa6dfe2a4ef21c068da1ec0c97c5d46a41631972e6850f8022b0b9d5e85881010f7028054 SHA512 abee57d6497566f8dfa32d273f0ef9cf914ed57b9397c61455695cbfc141fce8f1ccd2c65a2043ec0d4843dc0a1cde978a0b8b05bcc12e71a7438cd379a462c5
+DIST Math-BigInt-Lite-0.17.tar.gz 71248 BLAKE2B dd570295271ebae319ac4233ec9d274b569474ae2a7d95c86bb9e030dcce13d7c2e6b124cd8d0c37179ba2cb51147cdc2a988e5b8261b3cb3f072a68ebce5932 SHA512 8a1eb42d43a09cc7e16a9c430c6fb1a9c2f799e1dd3cb67436a6fafff510ed39550d4db8d28f5992c754c8391e0e9700b230e9b74dd05a108faecc9f0e55ef4e
+EBUILD Math-BigInt-Lite-0.140.0.ebuild 864 BLAKE2B dc10597c6284e93dccb6678f89fdd0eb7643da90cc4600bd246244d4309a8e24c318f8d97ff7a0c691a43d17475117fc272c6829ab73c7973f11a90548f4ef8a SHA512 b54fbf773d8a58e644d1148aafd3f660d5724986c9192c3051994b1fcc6cd0d366ebc90b197d4012193f3b358735df5263e99d1b34eb11643a6e99420525f166
+EBUILD Math-BigInt-Lite-0.170.0.ebuild 716 BLAKE2B 17045737cbf3964ad2cf3b8daeee13b73a37000e8b38647cfd4c4e077f251fd9dbefef704d3426bb070f09ff57ec236c9c92a4ee95a00e25f1caffb863972e7b SHA512 9920820da5b68f0ff51958c4b47485f0fd2a0283f26a034bfec1db1ae6a19acb09e3f7a0fef631131238b5b06d7f525efcd65555362c639c6ac9275ea6b26add
+MISC metadata.xml 393 BLAKE2B a83f8f4f92d45e599d7ea9f4492ca9226d001a3ecbfcadaf8b69446966d0b390a87e35107e6e6f8d124ba58935deefe8a1e7b128d4306d0f218d503537b5af3e SHA512 58bce0e0b37f3d0504470c88ea135563384d372d56da8b897c9387ced0171e7dacc106eb1c61bd69e4f8e70719ca8946bc9e06332d7716182bf2a31dd6c1188e
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
new file mode 100644
index 000000000000..81877108927a
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="FLORA"
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.940.0
+ >=virtual/perl-Math-BigRat-0.190.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.520.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ bad_files+=( "t/bigintpm.t" )
+
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
new file mode 100644
index 000000000000..037b684079f9
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.801
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ virtual/perl-Math-BigRat
+ )
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ #bad_files+=( "t/bigintpm.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}
diff --git a/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch b/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch
new file mode 100644
index 000000000000..d8ae23982ae7
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch
@@ -0,0 +1,34 @@
+From 5cb03904937102876d331e04cd36f3520fc5a5f6 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Nov 2017 20:50:35 +1300
+Subject: Fix tests without '.' in @INC
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120893
+---
+ t/bigintpm.t | 2 +-
+ t/mbi_ali.t | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/bigintpm.t b/t/bigintpm.t
+index 49efbad..a714bd0 100644
+--- a/t/bigintpm.t
++++ b/t/bigintpm.t
+@@ -14,4 +14,4 @@ $CALC = "Math::BigInt::Calc";
+ #############################################################################
+ # all the other tests
+
+-require 't/bigintpm.inc'; # all tests here for sharing
++require './t/bigintpm.inc'; # all tests here for sharing
+diff --git a/t/mbi_ali.t b/t/mbi_ali.t
+index cacf83e..b2da6f9 100644
+--- a/t/mbi_ali.t
++++ b/t/mbi_ali.t
+@@ -12,4 +12,4 @@ use Math::BigInt::Lite;
+ our $CLASS;
+ $CLASS = 'Math::BigInt::Lite';
+
+-require 't/alias.inc';
++require './t/alias.inc';
+--
+2.14.3
+
diff --git a/dev-perl/Math-BigInt-Lite/metadata.xml b/dev-perl/Math-BigInt-Lite/metadata.xml
new file mode 100644
index 000000000000..170ab1fe752f
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-BigInt-Lite</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Lite</remote-id>
+ </upstream>
+</pkgmetadata>