summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-IMAPClient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Mail-IMAPClient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Mail-IMAPClient')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.370.0.ebuild35
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild46
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild48
-rw-r--r--dev-perl/Mail-IMAPClient/Manifest9
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch89
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch89
-rw-r--r--dev-perl/Mail-IMAPClient/metadata.xml27
7 files changed, 343 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.370.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.370.0.ebuild
new file mode 100644
index 000000000000..a7ae55b1eedf
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.370.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=PLOBBES
+MODULE_VERSION=3.37
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.940.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild
new file mode 100644
index 000000000000..6147c3cf4977
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.38
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+)
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.967.9
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
new file mode 100644
index 000000000000..95638104d953
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.39
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+ "t/pod.t" # Bad author test
+)
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.967.9
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Mail-IMAPClient/Manifest b/dev-perl/Mail-IMAPClient/Manifest
new file mode 100644
index 000000000000..3f6193380c66
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Manifest
@@ -0,0 +1,9 @@
+AUX 3.38-makefilepl.patch 2592 BLAKE2B f19b22a6f32c6acb1cdfd2bbf7f6a14d1d4b360933c5832e949be73e21167b3eb814078466722ee35fb582271b46e0c0b65125ee16e3a1fa73bd8962fc346789 SHA512 007dd94afc738de520317275c940569bc4bb95b4a70eb8e0699c59c23a9e58d2bd68f5ae73ceeb7b7e9b84cf1f61f1e28ed0f05a20eff89191589b9342d443d1
+AUX 3.39-makefilepl.patch 2592 BLAKE2B f19b22a6f32c6acb1cdfd2bbf7f6a14d1d4b360933c5832e949be73e21167b3eb814078466722ee35fb582271b46e0c0b65125ee16e3a1fa73bd8962fc346789 SHA512 007dd94afc738de520317275c940569bc4bb95b4a70eb8e0699c59c23a9e58d2bd68f5ae73ceeb7b7e9b84cf1f61f1e28ed0f05a20eff89191589b9342d443d1
+DIST Mail-IMAPClient-3.37.tar.gz 188964 BLAKE2B 24cb8b98476cdf424d515e4a6d640b3290b187a83851aff5b150db78bce3de65c939846c0a7714ce13030737a9e98d41de09774544f2e35aae810dcd6990b87a SHA512 e6baeb880610d55991342fc50acd5bb666a4d94856f4d158172eb5e430aa62296847cb4cec4706398dfbaf7af657ca0024ef92bbb455addd0cd648c47d847fef
+DIST Mail-IMAPClient-3.38.tar.gz 190487 BLAKE2B 0eceee1152eb82f6bffc58fdc18ced421072b6a0902d1e4c51da07e6415c9697e03d5c7e6f9785ba821cdd1550fdf069ed56b7dbe7226650b040012b4165ca4c SHA512 aa2d4ae43ac221db5b99d20884d34ce41fabdc593cee48e7daf7d7048dd351026231f9a4193044f42eb17c8d303b5af0b924bea17fed27c4d0934ca2935b73f3
+DIST Mail-IMAPClient-3.39.tar.gz 190965 BLAKE2B 43fb640d2282945b21e743ccb8bec037103b7bcff78396f1f72f26d7860d5b5f69bcab837f3e857610426f958c860085f66cef21c8d5115940fc64ae3667f1e3 SHA512 156e5f6682d55f2c112ae5065448f0c502d3e748c4405768152ccccd7d944cf949f7c3fd42f30f40c86337457dea5c037959bf29739e4c413e4b45af2b74c222
+EBUILD Mail-IMAPClient-3.370.0.ebuild 635 BLAKE2B c9d961c260f8cb342527c0f91a24cb565198fa6bf2e85d431d314273c48a76e27a6f4f122579838d13600ea8e5cf30474cbdfb41237b0b76e2208617356bb863 SHA512 5b4f0d8e026babf27ee68cc6bfb52828b5fcfb5294ecc390417ea348b7b43dafde976a51dfebcc978a2aab7b3a5ad0e06801074466f54bf79e6ff630c467a46f
+EBUILD Mail-IMAPClient-3.380.0.ebuild 1026 BLAKE2B 4713df792f90dd96e838b2d6e922d93327afefbf3b0fe02c6a6c3c070ba16954481502a7a76e5a5452ae6df75adbcc83590f3ba58499f4aa77c37046c40b3c81 SHA512 fcdfff8994d01782c76237c53bbc753ca004e5f71503c1024207d47b4aa9421952a44a61f637389af6f5c3683691041bde2da12db13cc8206b36db0b85e65498
+EBUILD Mail-IMAPClient-3.390.0.ebuild 1086 BLAKE2B 7df75d8d9d7911e97170daef44c565bd3387f2d77dd373b7c5d7c57ad68db20774a28f2c48c05bcbda52f0eb0dec9f5ff158b2947b4782a9b2afdf6cc9e81335 SHA512 ef1272c4dfb6db2ff5b6c2ecc23e88f8d81059c731ef8b8f97a6280cdfecef462c7279f49e71e5cd77e0e89a0b6e330eb19b0032e07633ebd607317a532276a6
+MISC metadata.xml 1479 BLAKE2B c6dd142a9311a0e0d425ef22933e04327f24d53cb41d8428d14de58806be9a55be319382e1f07bf445c8f35d83842d915ad7cacbfc47621f957a8484985369e1 SHA512 9ab467eb24b4805b0b505cc0a4c950206281d65ea4868d2aa759c94457e1bb8a382ee7ac84627392f3e3416056da7e1aa87f0de810c1d9fc63d39628040ecddf
diff --git a/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch
new file mode 100644
index 000000000000..1224701a2988
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -Naur Mail-IMAPClient-3.38/Makefile.PL Mail-IMAPClient-3.38/Makefile.PL
+--- Mail-IMAPClient-3.38/Makefile.PL
++++ Mail-IMAPClient-3.38/Makefile.PL
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- http://search.cpan.org/
+- http://www.perl.com/CPAN/modules/by-module
+- http://www.perl.org/CPAN/modules/by-module
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -94,45 +61,4 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+-
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}
diff --git a/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch
new file mode 100644
index 000000000000..1224701a2988
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -Naur Mail-IMAPClient-3.38/Makefile.PL Mail-IMAPClient-3.38/Makefile.PL
+--- Mail-IMAPClient-3.38/Makefile.PL
++++ Mail-IMAPClient-3.38/Makefile.PL
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- http://search.cpan.org/
+- http://www.perl.com/CPAN/modules/by-module
+- http://www.perl.org/CPAN/modules/by-module
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -94,45 +61,4 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+-
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}
diff --git a/dev-perl/Mail-IMAPClient/metadata.xml b/dev-perl/Mail-IMAPClient/metadata.xml
new file mode 100644
index 000000000000..0ab914be90f3
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <use>
+ <flag name="ntlm">Install support for NTLM Authentication</flag>
+ <flag name="md5">Install support for DIGEST-MD5 and CRAM-MD5 Authentication</flag>
+ <flag name="ssl">Install support for SSL Connections</flag>
+ <flag name="zlib">Install support for COMPRESS DEFLATE connections</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">Mail-IMAPClient</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Address</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Envelope</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Parse</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Part</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::MessageSet</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::Thread</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Mail::IMAPClient::BodyStructure::Parse</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Mail::IMAPClient::Thread</remote-id>
+ </upstream>
+</pkgmetadata>