summaryrefslogtreecommitdiff
path: root/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild')
-rw-r--r--dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild b/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
new file mode 100644
index 000000000000..61331ec36a66
--- /dev/null
+++ b/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=3.033
+inherit perl-module
+
+DESCRIPTION="Low-calorie MIME generator"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="minimal"
+
+PATCHES=( "${FILESDIR}/3.033-makefilepl.patch" )
+
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
+
+# MIME::QuotedPrint -> perl-MIME-Base64
+# Mail::Address -> MailTools
+RDEPEND="
+ !minimal? (
+ virtual/perl-MIME-Base64
+ >=dev-perl/MIME-Types-1.280.0
+ >=dev-perl/MailTools-1.620.0
+ )
+ dev-perl/Email-Date-Format
+ virtual/perl-File-Spec
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# Race condition in "testout" directory creation
+DIST_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ insinto /usr/share/${PN}
+ doins -r contrib
+}