summaryrefslogtreecommitdiff
path: root/dev-perl/Log-Agent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Log-Agent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Log-Agent')
-rw-r--r--dev-perl/Log-Agent/Log-Agent-1.1.0.ebuild23
-rw-r--r--dev-perl/Log-Agent/Manifest4
-rw-r--r--dev-perl/Log-Agent/files/Log-Agent-1.1.0-no-dot-inc.patch193
-rw-r--r--dev-perl/Log-Agent/metadata.xml37
4 files changed, 257 insertions, 0 deletions
diff --git a/dev-perl/Log-Agent/Log-Agent-1.1.0.ebuild b/dev-perl/Log-Agent/Log-Agent-1.1.0.ebuild
new file mode 100644
index 000000000000..edcbc2a2ca92
--- /dev/null
+++ b/dev-perl/Log-Agent/Log-Agent-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MROGASKI
+DIST_VERSION=1.001
+inherit perl-module
+
+DESCRIPTION="A general logging framework"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+DIST_TEST=do
diff --git a/dev-perl/Log-Agent/Manifest b/dev-perl/Log-Agent/Manifest
new file mode 100644
index 000000000000..363c6c55c238
--- /dev/null
+++ b/dev-perl/Log-Agent/Manifest
@@ -0,0 +1,4 @@
+AUX Log-Agent-1.1.0-no-dot-inc.patch 4048 BLAKE2B 8e5f2481524d0526f4469c32b16e234f8224546d348597a8309451dca0cff2a1972602a9aa87905ef7ff98342882b6ed3752594b1a8f5f5fcb891b206534a33f SHA512 4aca7bdb2eab4405028bfe7e8a1fe2fbcfc7db7f4b0302d9a753944586c5558bdc4c4c161a557f2e865d27172b0c78a685c74b5d9c38d4097c83038959b8d970
+DIST Log-Agent-1.001.tar.gz 56215 BLAKE2B a73673f718233dc915f6e3cb4ef6a7a8455ad196190ae378abb20db31eb848a8c41069d069ce69fbf25aad75fb3c6ebb47d80694dee5cd97364e64b778be0545 SHA512 b8d3a15e40129add73bb4967ecc5daf37c0fd8a17eb75ed86fe338a9eb228b37ddd56b9bbf9bdef91f8453eb1b53d7fe303a96f68cbb0834820f2354fa37b5e7
+EBUILD Log-Agent-1.1.0.ebuild 598 BLAKE2B 557016c4ad89e172c461d744fa51348c075fa66c166c247a7b702d2644b154a6b5838c199964e43654e4a5611028f1d53d7412280a975cf8fddd3ce6f3018894 SHA512 8d30918ff376cd5c4d8d000b05e40f8269825d7ef1ab9036506578f71609e0fbbb77de0a078f3585aeb57e513b8f4585e0ba8a883962c0300d7727949968785d
+MISC metadata.xml 2136 BLAKE2B b74238e39f7a213eaadd5db4f41768506e31af780d85a7ce1bd3bcd087c043d8fb674b5fb2da6fc96251583420ad61e62c4d3f4781ecec58b9a8eb21fa725421 SHA512 1a707e2e4710a690bbc44ff37f551b8e03e5b88c270d219dc5da5d5604599c93d5d14880956d3ca3df1b83e434ff8fa5264121880e3319dc78b963cc8f8c82b2
diff --git a/dev-perl/Log-Agent/files/Log-Agent-1.1.0-no-dot-inc.patch b/dev-perl/Log-Agent/files/Log-Agent-1.1.0-no-dot-inc.patch
new file mode 100644
index 000000000000..e46c0bda2a7d
--- /dev/null
+++ b/dev-perl/Log-Agent/files/Log-Agent-1.1.0-no-dot-inc.patch
@@ -0,0 +1,193 @@
+From f85b4f6c097338ff07c5736fbe77dd09d2bca289 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 26 Oct 2017 21:02:47 +1300
+Subject: Fix test failures due to '.' removal from @INC under Perl 5.26
+
+when PERL_USE_UNSAFE_INC=0
+
+Bug: https://bugs.gentoo.org/617050
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121459
+Bug: https://github.com/mrogaski/Log-Agent/pull/13
+---
+ t/caller.t | 2 +-
+ t/carp.pl | 4 ++--
+ t/carp_default.t | 2 +-
+ t/carp_file.t | 2 +-
+ t/carp_fork.t | 2 +-
+ t/carp_silent.t | 2 +-
+ t/default.t | 2 +-
+ t/default_exp.t | 2 +-
+ t/file.t | 2 +-
+ t/fork.t | 2 +-
+ t/priority.t | 2 +-
+ t/tag_callback.t | 2 +-
+ t/tag_string.t | 2 +-
+ 13 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/t/caller.t b/t/caller.t
+index 6a14aa6..feb3c2c 100644
+--- a/t/caller.t
++++ b/t/caller.t
+@@ -14,7 +14,7 @@
+
+ print "1..10\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+diff --git a/t/carp.pl b/t/carp.pl
+index a4327e1..352f7d6 100644
+--- a/t/carp.pl
++++ b/t/carp.pl
+@@ -14,10 +14,10 @@
+
+ print "1..11\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+-my $FILE = "t/carp.pl";
++my $FILE = "./t/carp.pl";
+
+ package OTHER;
+ use Log::Agent;
+diff --git a/t/carp_default.t b/t/carp_default.t
+index 293ddb7..819e438 100644
+--- a/t/carp_default.t
++++ b/t/carp_default.t
+@@ -20,4 +20,4 @@ select(ORIG_STDOUT);
+ open(STDOUT, ">t/file.out") || die "can't redirect STDOUT: $!\n";
+ open(STDERR, ">t/file.err") || die "can't redirect STDOUT: $!\n";
+
+-do 't/carp.pl';
++do './t/carp.pl';
+diff --git a/t/carp_file.t b/t/carp_file.t
+index 9e5e9a3..8239d62 100644
+--- a/t/carp_file.t
++++ b/t/carp_file.t
+@@ -27,4 +27,4 @@ my $driver = Log::Agent::Driver::File->make(
+ );
+ logconfig(-driver => $driver);
+
+-do 't/carp.pl';
++do './t/carp.pl';
+diff --git a/t/carp_fork.t b/t/carp_fork.t
+index c81a86b..dcf8131 100644
+--- a/t/carp_fork.t
++++ b/t/carp_fork.t
+@@ -29,4 +29,4 @@ my $driver = Log::Agent::Driver::Fork->make(
+ );
+ logconfig(-driver => $driver);
+
+-do 't/carp.pl';
++do './t/carp.pl';
+diff --git a/t/carp_silent.t b/t/carp_silent.t
+index 6c7c8ca..c913308 100644
+--- a/t/carp_silent.t
++++ b/t/carp_silent.t
+@@ -14,7 +14,7 @@
+
+ print "1..2\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+diff --git a/t/default.t b/t/default.t
+index eadca93..73bab3a 100644
+--- a/t/default.t
++++ b/t/default.t
+@@ -14,7 +14,7 @@
+
+ print "1..4\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+diff --git a/t/default_exp.t b/t/default_exp.t
+index 5fc95b7..940e1eb 100644
+--- a/t/default_exp.t
++++ b/t/default_exp.t
+@@ -19,7 +19,7 @@
+
+ print "1..8\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+diff --git a/t/file.t b/t/file.t
+index 57caaba..e7487ee 100644
+--- a/t/file.t
++++ b/t/file.t
+@@ -15,7 +15,7 @@
+ use Test::More;
+ use Log::Agent;
+ require Log::Agent::Driver::File;
+-require 't/common.pl';
++require './t/common.pl';
+
+ BEGIN { plan tests => 38 }
+
+diff --git a/t/fork.t b/t/fork.t
+index a943a89..5726ba2 100644
+--- a/t/fork.t
++++ b/t/fork.t
+@@ -14,7 +14,7 @@
+
+ use strict;
+ use Test;
+-require 't/common.pl';
++require './t/common.pl';
+
+ BEGIN { plan tests => 19 }
+
+diff --git a/t/priority.t b/t/priority.t
+index 3e5be89..3f6b2c4 100644
+--- a/t/priority.t
++++ b/t/priority.t
+@@ -14,7 +14,7 @@
+
+ print "1..5\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+diff --git a/t/tag_callback.t b/t/tag_callback.t
+index 64a1bd4..39b749d 100644
+--- a/t/tag_callback.t
++++ b/t/tag_callback.t
+@@ -12,7 +12,7 @@
+ #
+ ##########################################################################
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ eval "require Callback";
+diff --git a/t/tag_string.t b/t/tag_string.t
+index 843fc10..b4851c2 100644
+--- a/t/tag_string.t
++++ b/t/tag_string.t
+@@ -14,7 +14,7 @@
+
+ print "1..2\n";
+
+-require 't/code.pl';
++require './t/code.pl';
+ sub ok;
+
+ use Log::Agent;
+--
+2.14.3
+
diff --git a/dev-perl/Log-Agent/metadata.xml b/dev-perl/Log-Agent/metadata.xml
new file mode 100644
index 000000000000..b93c854955b3
--- /dev/null
+++ b/dev-perl/Log-Agent/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Log-Agent</remote-id>
+ <remote-id type="cpan-module">Log::Agent</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Channel</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Channel::File</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Channel::Handle</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Channel::Syslog</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Datum</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Default</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::File</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Fork</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Mail</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Silent</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Driver::Syslog</remote-id>
+ <remote-id type="cpan-module">Log::Agent::File::Native</remote-id>
+ <remote-id type="cpan-module">Log::Agent::File_Pool</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Formatting</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Message</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Prefixer</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Priorities</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Stamping</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag::Callback</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag::Caller</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag::Priority</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag::String</remote-id>
+ <remote-id type="cpan-module">Log::Agent::Tag_List</remote-id>
+ </upstream>
+</pkgmetadata>