summaryrefslogtreecommitdiff
path: root/dev-perl/List-AllUtils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/List-AllUtils
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/List-AllUtils')
-rw-r--r--dev-perl/List-AllUtils/List-AllUtils-0.140.0.ebuild28
-rw-r--r--dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild26
-rw-r--r--dev-perl/List-AllUtils/Manifest7
-rw-r--r--dev-perl/List-AllUtils/metadata.xml12
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/List-AllUtils/List-AllUtils-0.140.0.ebuild b/dev-perl/List-AllUtils/List-AllUtils-0.140.0.ebuild
new file mode 100644
index 000000000000..0b94650572fe
--- /dev/null
+++ b/dev-perl/List-AllUtils/List-AllUtils-0.140.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="Combines many List::* utility modules in one bite-sized package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+LICENSE="Artistic-2"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/List-SomeUtils-0.500.0
+ >=virtual/perl-Scalar-List-Utils-1.450.0
+ >=dev-perl/List-UtilsBy-0.100.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild b/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild
new file mode 100644
index 000000000000..52858846c551
--- /dev/null
+++ b/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION='Combines List::Util and List::MoreUtils in one bite-sized package'
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-perl/List-MoreUtils-0.280.0
+ >=virtual/perl-Scalar-List-Utils-1.310.0"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warnings )"
+
+SRC_TEST="do"
diff --git a/dev-perl/List-AllUtils/Manifest b/dev-perl/List-AllUtils/Manifest
new file mode 100644
index 000000000000..360ac8b88fc8
--- /dev/null
+++ b/dev-perl/List-AllUtils/Manifest
@@ -0,0 +1,7 @@
+DIST List-AllUtils-0.08.tar.gz 19283 SHA256 27ddc2f0d47656cd3e08846ffe19f765bbd6c1d0e3c751ce4bb704e2b0b7ad1f SHA512 112591ad2c0ecfdbe2757e96827d5ea8f6d2b47491ace9ba406270fb6d15626a28da2381ef27231c61b7b4b42dc1bdeb323defa751d9a5cd20ca2cf489cd28e3 WHIRLPOOL e8191107c7f1a7beaf43e08fabd84ace25c4a6b5859e1eefb8c0b4a378abcf3620f2c0fd15f3b2a412dc5a9d757f6d905b2e849461e5d833662eb3cdc13d91a5
+DIST List-AllUtils-0.14.tar.gz 44358 SHA256 e45aa65927ae1975a000cc2fed14274627fa5e2bd09bab826a5f2c41d17ef6cd SHA512 1a9a292cf92cfe24d8aeb5154fb55e399eebca1063393d001bdd3c5dc19d4672012c1e0ccd84be06c12a6f1fc99021e35806ec943e5477cbf87d143b7fc2c17a WHIRLPOOL 71a5371ff6cd1dddd989ce5e64207dc392f9f0d865e375c42f33cebfd17e0934c834d6bbdc0c817f532d8281b778bee7bae1a1ac6215e5c454bcf524d242b42f
+EBUILD List-AllUtils-0.140.0.ebuild 725 SHA256 ab8f6731142d48d5e0dd3167437a8a69c592eb4b25184115c642b6aa317766c0 SHA512 b713d4e3f179a652893591a55e7ffc6530269965a84d0d33b8b5dddae14b5af5e85475a127d4643bdd4b9821bec49cf66e2e14c60cc789127ddcf0b0b2153e18 WHIRLPOOL 11f957a08da60e63de84bd8d708d37850aa51750710c3285927e4bb393a5440410b31531b3348a3d539d4003bbfca999d1bcea14cca670c4d0c32aba8cf71270
+EBUILD List-AllUtils-0.90.0.ebuild 724 SHA256 0adc19cfe41f48be2db35e19bac35c9006008d8e168aa5a55ea450f06e75acb5 SHA512 c124f961c789afca9d383759d57b1ccd47f0b89e8def0ba3f3cdd746e56260cedca9c0ed647d08f04897bb0fe3387c3a2f5acd1b31189dfc9249f9c233e622bc WHIRLPOOL a937abbec97d9ea455e00066fbc7616193929427edba5a2c7d7ae5b6d9a0a1b259094652871790499cf39ad46ee63aab9089c83dcaece663708ff5f09cff7d08
+MISC ChangeLog 2758 SHA256 aa8c11441acbf570b924926cd6b3bf33cbd9f72386a7f50d167ec95ad54a18f9 SHA512 ea307a7a5c548b786b4d14d9bb1ee3e23ccb9115aaf6ead47a76ecc24a4c311acbe52ea2e5cc9b233691ff33fcdac324f90495e4affe39ff1c0127aa3b10e290 WHIRLPOOL 148ab6cf9d6d402827d5c1e1b10f79b8ecc8d4fb38ccc218529d90db5f2fdca0bbfcae5aca280956b82bd15dff182007c0a8defc81df7fdcf104ee3e91f37270
+MISC ChangeLog-2015 3129 SHA256 bd4ae4c860366840830669940fb8db05696a5883b5a8ad80694c46dae477d704 SHA512 d6d37798ec3444cf6c300cdb6631580075b08e1a6eec7a0be919715309e4264198a0d20fbad790b0a689c0f4fe02d22bb6d563368c50073f804e495b423f028e WHIRLPOOL 7277e88cdec6c02e9d6931a899007018f787f2ae8b6a510ca72cf702adc3bfdb5441149af12093e797312050c5b870683bf1da858d451bdc00f326b9323fd05c
+MISC metadata.xml 398 SHA256 0e4b6037aab244eaa2e3a93dd7bf5e581e6466cf7ba3840ff3da94e87b301172 SHA512 fad0151a2b023636c8a18bd17e12b248bf56f2e509edfb5927d1f7d03ebee1ed21a6d2e91bd716aa77e2185bd32b54b573b812d7dfce6966878c0c4983757c9e WHIRLPOOL bcf51e3c44dfeecc0b6bc8dc84b1e7471685bcea6b11219462f34f236d7d4549edad0d56e1d4dc0497cf56e59c6cb08b192c3313ec1ade59d8a7fb796abd7d3c
diff --git a/dev-perl/List-AllUtils/metadata.xml b/dev-perl/List-AllUtils/metadata.xml
new file mode 100644
index 000000000000..3779f05fa496
--- /dev/null
+++ b/dev-perl/List-AllUtils/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">List-AllUtils</remote-id>
+ <remote-id type="cpan-module">List::AllUtils</remote-id>
+ </upstream>
+</pkgmetadata>