summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Online
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/LWP-Online
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/LWP-Online')
-rw-r--r--dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild33
-rw-r--r--dev-perl/LWP-Online/Manifest4
-rw-r--r--dev-perl/LWP-Online/files/1.08-no-network.patch30
-rw-r--r--dev-perl/LWP-Online/metadata.xml13
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
new file mode 100644
index 000000000000..06203c876658
--- /dev/null
+++ b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Does your process have access to the web"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+
+# https://rt.cpan.org/Public/Bug/Display.html?id=112728
+PATCHES=("${FILESDIR}/${DIST_VERSION}-no-network.patch")
+
+# LWP::Simple -> libwww-perl
+RDEPEND="
+ >=dev-perl/libwww-perl-5.805.0
+ >=dev-perl/URI-1.350.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.420.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL 1\.01;/use lib q[.];\nuse inc::Module::Install::DSL 1.01;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/LWP-Online/Manifest b/dev-perl/LWP-Online/Manifest
new file mode 100644
index 000000000000..1e3909f2c87f
--- /dev/null
+++ b/dev-perl/LWP-Online/Manifest
@@ -0,0 +1,4 @@
+AUX 1.08-no-network.patch 1029 BLAKE2B dcd74d51a01bdd61d7ac6ca89f9198c57141168907d51179fe7d4dfb461b3aaa725a0493e25ed807095bab5c7e0cc97b2ec5d49fc6afb01d924dcff1fec57e2f SHA512 1bedc7075021fcf7e8be1fbe972ce26f39af5ac2b46ccad96697ae05ac87f6bb8303e78c4c2b67f096ec22f39265a95ff5d86a64b13f9d364ae608593f0bc0a1
+DIST LWP-Online-1.08.tar.gz 32250 BLAKE2B 4696ef7d50498b5373bd52568afac5876aa7afbe41ca6fed0029274bc0b52e05b005179fa520a63c2e43e9ba78df0dc1e99a2011f4ff13915f2cad829e706064 SHA512 2b255f60ee6521757ce3d49cc0720e3985ff17e3db7b7868ced6a9e1c5444dc067c80b7d34dbe7be9679c134f3de1dbe0e9421a1a20ff388c812aacd1d964497
+EBUILD LWP-Online-1.80.0-r2.ebuild 845 BLAKE2B f5ad58f709347054be61f65f0f971c9c523111ce16f4128bba196880ff94dd9df76e18b015cbbe752b5e06069bb5d5380b4e10da40bc531b1c13c2cdf7a46447 SHA512 e6dbe4fc14328c9f2a6053089444150f2ae8b8c0fe896b5416dee802a3f6b5292f941987fcef8154d4df7c0a07a019cb4477d90d7e9c9c2288551d12f8795c9f
+MISC metadata.xml 506 BLAKE2B 8946eac364e58e9d3965e0baa455a1b09fa28a77a6b021c52ce9fe168f172591142f2ff69a8a0988adaa6fb2b1e6ed63b428e8d5e4262628dc0b76583a55d859 SHA512 d8ba13433a74f5ce01cbf7f8813d5694ccafdd1eb5e6eb52aa37e5e5ead36063c782e777c791cc740850e69af6543b2122d7e714afa173b1748a9d40861ec7d4
diff --git a/dev-perl/LWP-Online/files/1.08-no-network.patch b/dev-perl/LWP-Online/files/1.08-no-network.patch
new file mode 100644
index 000000000000..e6b0419eef09
--- /dev/null
+++ b/dev-perl/LWP-Online/files/1.08-no-network.patch
@@ -0,0 +1,30 @@
+diff -Naur LWP-Online-1.08/lib/LWP/Online.pm LWP-Online-1.08b/lib/LWP/Online.pm
+--- LWP-Online-1.08/lib/LWP/Online.pm 2011-07-08 07:02:25.000000000 +0000
++++ LWP-Online-1.08b/lib/LWP/Online.pm 2016-03-06 06:20:12.351333667 +0000
+@@ -167,6 +167,9 @@
+ my @functions = grep { $_ ne ':skip_all' } @_;
+ if ( @functions != @_ ) {
+ require Test::More;
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ Test::More->import( skip_all => 'NO_NETWORK_TESTING set' );
++ }
+ unless ( online() ) {
+ Test::More->import( skip_all => 'Test requires a working internet connection' );
+ }
+diff -Naur LWP-Online-1.08/t/02_main.t LWP-Online-1.08b/t/02_main.t
+--- LWP-Online-1.08/t/02_main.t 2011-07-08 07:02:25.000000000 +0000
++++ LWP-Online-1.08b/t/02_main.t 2016-03-06 06:14:41.521243616 +0000
+@@ -7,7 +7,12 @@
+ $| = 1;
+ $^W = 1;
+ }
+-
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ require Test::More;
++ Test::More->import('skip_all', "NO_NETWORK_TESTING set");
++ }
++}
+ use Test::More tests => 6;
+ use LWP::Online 'online', 'offline';
+
diff --git a/dev-perl/LWP-Online/metadata.xml b/dev-perl/LWP-Online/metadata.xml
new file mode 100644
index 000000000000..d26c68e43613
--- /dev/null
+++ b/dev-perl/LWP-Online/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>LWP::Online is a Perl Module for testing the state of internet accessibility</longdescription>
+ <upstream>
+ <remote-id type="cpan">LWP-Online</remote-id>
+ <remote-id type="cpan-module">LWP::Online</remote-id>
+ </upstream>
+</pkgmetadata>