summaryrefslogtreecommitdiff
path: root/dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild')
-rw-r--r--dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild b/dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild
new file mode 100644
index 000000000000..adc76d9b49f2
--- /dev/null
+++ b/dev-perl/JSON-MaybeXS/JSON-MaybeXS-1.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=1.004003
+inherit perl-module
+
+DESCRIPTION="Use Cpanel::JSON::XS with a fallback to JSON::XS and JSON::PP"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+xs"
+
+# needs Scalar-Util
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-JSON-PP-2.273.0
+ virtual/perl-Scalar-List-Utils
+ xs? (
+ || (
+ >=dev-perl/Cpanel-JSON-XS-2.331.0
+ >=dev-perl/JSON-XS-3.0.0
+ )
+ )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Needs-0.2.6
+ )
+"