summaryrefslogtreecommitdiff
path: root/dev-perl/IO-Compress-Brotli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 03:34:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 03:34:39 +0000
commiteb147001d2176fe9850e42017a6b1284baf865ff (patch)
tree7b89220afbe07cd8fe6436d28af80d17a6f11a58 /dev-perl/IO-Compress-Brotli
parent5c0cc325922d72d6e614def2a9b36ee95a46d2c1 (diff)
gentoo auto-resync : 29:10:2023 - 03:34:39
Diffstat (limited to 'dev-perl/IO-Compress-Brotli')
-rw-r--r--dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.10.0.ebuild29
-rw-r--r--dev-perl/IO-Compress-Brotli/Manifest3
-rw-r--r--dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch50
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.10.0.ebuild b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.10.0.ebuild
new file mode 100644
index 000000000000..da2771717f73
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TIMLEGGE
+DIST_VERSION=0.010
+inherit perl-module
+
+DESCRIPTION="Read/write Brotli buffers/streams"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/brotli:=
+ dev-perl/File-Slurper
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+"
+DEPEND="
+ app-arch/brotli:=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.010-unbundle.patch
+)
diff --git a/dev-perl/IO-Compress-Brotli/Manifest b/dev-perl/IO-Compress-Brotli/Manifest
index 197510090bb8..2c133385906f 100644
--- a/dev-perl/IO-Compress-Brotli/Manifest
+++ b/dev-perl/IO-Compress-Brotli/Manifest
@@ -1,4 +1,7 @@
AUX IO-Compress-Brotli-0.004001-unbundle.patch 1187 BLAKE2B 9a388d5eb74a06ad30c98dba48b08a829e9a79065fe74f456c9424cc53be2070540c167e86e17b00d113766ad801839403e5e565b047c63390ed0f86c5239786 SHA512 30f5ef7039012ca92cfd2fb40eecadfb2f6f3e118b7e008d4ec05e64d404990cc61ff7c8d3926e7bd0fb78a273570f54331faa4986200e97664bc8a2d382dc6c
+AUX IO-Compress-Brotli-0.010-unbundle.patch 1702 BLAKE2B c24f42f98001aa0366a6de03cfad2ac5be1d4aa67cd5fe39b73c3e409dfb5c1832d434d2a19a25dc00ba59fc777776e0c5f3f9408caf3982f56b07eca7835113 SHA512 db407f2d20f8bd6f1b48aa5dd40d1b2a467c6e0bf2660b351f12dc184f276d9355d4136178e8324da702276f97d5cf4ceece0506f9c8a712fcdb941efe03dc96
DIST IO-Compress-Brotli-0.004001.tar.gz 7674244 BLAKE2B b3c4d6a1101429fc47f345f0ba119e5196873a0e5d368b31d02f76ca2a0ac269ed4c9c82972de527052b55e73a2a4724ebf4f644c23c383304082413b512dfad SHA512 7cc198ecef15c912d8b62e6851935c433159e7f3680f2034949c032d23827f5a5720dd02b77b89b60d43b0a2a7df059c9e76c8f4e44993c28630624f0e17a377
+DIST IO-Compress-Brotli-0.010.tar.gz 7746600 BLAKE2B 121736c8fed73188d1e717296265ab1d716ab9b73b1540424f1b03533401b8a5843e172a138c4c63e3c82b5dfd5b6a5e6eb10ef6adb99b3548ddb860a3b74580 SHA512 8536c15c1e808f1785c2361b87277b5090c563d8c4111d9ca9358266610a18f7512438dcef9eacb2ef5c8bf0cbd737aacd86f196f6ad674e4d68342d5fc4d184
+EBUILD IO-Compress-Brotli-0.10.0.ebuild 500 BLAKE2B 7cc590bba68767852b2f02a0410e6ae2b5cf1fd0954dbb15a614e5f30e0b6c7f3bd6e70480a66aedc118861025f38bb3984e78fff6e0a0f6395db45493c0f99e SHA512 ed87f293afc4b11b180b60161ba3b35679e2fd66f4f6cb7d2a47dec2f0e524281f9dff9cc5e88ef0fd1b887de38a7b923e37917dad3aadf46422be6d63219b47
EBUILD IO-Compress-Brotli-0.4.1.ebuild 502 BLAKE2B 308af9691e557ee76eee59567ceccbcba05675222330855cd9f11f831459d3922748e591fe9423b963a3440abed91c8c97de7a5585b5de2fe5415842dca7d588 SHA512 6129009894c6f12aa6ec34b83d0c32b32c5b6c0ffb78b145913d5d61b01bae7c6076e94b5810c5b08a953a6976b1a672297f246629b4853dcd43aed0d08b63eb
MISC metadata.xml 479 BLAKE2B 840e5d4e561cee84296f10057764a7e4c3e5fe3c0ab6ecd2d13f8d06f1be254dc050a08122e7a85d3d58adc0bb7a03ea0aa8bbec77b2e368ef779fc9fe54491e SHA512 685aebeaef73a958bd71e9abe303d2729cd38f2eb7fdc484db10b74e3301ba690dec1c8394b71726a11e953ee92e4ea520386147f0038529cac015a0da7c0cd3
diff --git a/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch
new file mode 100644
index 000000000000..ab0fa2e133d8
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch
@@ -0,0 +1,50 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 3c92f12..00ff4e3 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,5 @@
+ use 5.014000;
+ use ExtUtils::MakeMaker;
+-use Alien::cmake3;
+ use File::Spec::Functions qw/catfile/;
+ use Config;
+
+@@ -9,6 +8,12 @@ if ($Config{myuname} =~ /strawberry/i) {
+ $cmake_options = ($Config{cc} =~ /gcc/i) ? ' -G "MinGW Makefiles" ' : '';
+ }
+
++my $bundled = $ENV{IO_COMPRESS_BROTLI_BUNDLED} || 0;
++
++# Avoid unnecessary dependency
++use if $bundled, 'Alien::cmake3';
++
++
+ WriteMakefile(
+ NAME => 'IO::Compress::Brotli',
+ VERSION_FROM => 'lib/IO/Compress/Brotli.pm',
+@@ -23,6 +28,7 @@ WriteMakefile(
+ 'Getopt::Long' => '0',
+ 'Time::HiRes' => '0',
+ },
++ ( $bundled ) ? (
+ CONFIGURE_REQUIRES => {
+ 'Alien::cmake3' => '0',
+ },
+@@ -32,6 +38,9 @@ WriteMakefile(
+ INC => '-Ibrotli/c/include',
+ MYEXTLIB => 'brotli/libbrotlienc$(LIB_EXT) brotli/libbrotlidec$(LIB_EXT) brotli/libbrotlicommon$(LIB_EXT)',
+ clean => { FILES => 'brotli/Makefile brotli/libbrotlienc$(LIB_EXT) brotli/libbrotlidec$(LIB_EXT) brotli/libbrotlicommon$(LIB_EXT) brotli/CMakeCache.txt brotli/CMakeFiles/* brotli/CTestTestfile.cmake brotli/DartConfiguration.tcl brotli/brotli brotli/cmake_install.cmake brotli/libbrotlicommon.pc brotli/libbrotlidec.pc brotli/libbrotlienc.pc' },
++ ) : (
++ LIBS => ['-lbrotlienc -lbrotlidec'],
++ ),
+ META_ADD => {
+ dynamic_config => 0,
+ resources => {
+@@ -41,6 +50,7 @@ WriteMakefile(
+ );
+
+ sub MY::postamble {
++ return '' unless $bundled;
+ my @dirs = Alien::cmake3->bin_dir;
+ my $cmake = defined $dirs[0] ? catfile($dirs[0] , Alien::cmake3->exe) : Alien::cmake3->exe;
+ '