summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild')
-rw-r--r--dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild b/dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild
new file mode 100644
index 000000000000..54fcf4e980b1
--- /dev/null
+++ b/dev-perl/HTML-Template/HTML-Template-2.970.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SAMTREGAR
+DIST_VERSION=2.97
+DIST_EXAMPLES=( "bench" "scripts/time_trial.pl" "templates" )
+inherit perl-module
+
+DESCRIPTION="A Perl module to use HTML Templates"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Digest-MD5
+ >=virtual/perl-File-Spec-0.820.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/CGI
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}