summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-TableContentParser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-perl/HTML-TableContentParser
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-perl/HTML-TableContentParser')
-rw-r--r--dev-perl/HTML-TableContentParser/Manifest1
-rw-r--r--dev-perl/HTML-TableContentParser/files/0.13-test.patch74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-perl/HTML-TableContentParser/Manifest b/dev-perl/HTML-TableContentParser/Manifest
index 8425cc2b18c3..1654e3d1ccb6 100644
--- a/dev-perl/HTML-TableContentParser/Manifest
+++ b/dev-perl/HTML-TableContentParser/Manifest
@@ -1,4 +1,3 @@
-AUX 0.13-test.patch 2076 BLAKE2B 4b3e46ada5bc7e3a9c7f6b105bbf804083abcd4d3c1873ee894468bf2ac49aa089b78583c061c83a34d37149a165efc85db0a40ea5b537e1455763a58abc5cad SHA512 39037bc38e5bd95f710dbfe005b05f2a355fa075b3f6de3681e6fc812e18850f9ab727ec9012761c6167b35302462223f4d2543dce6135ba63320b0751600bf9
DIST HTML-TableContentParser-0.304.tar.gz 18437 BLAKE2B 404ba11f9174cd3db019ede6078fca246722ff9ce1d2108cd689cfa3f79aebb178853143faa45022e5785daae5e79d1f21ad519099508c5554828d54da84e369 SHA512 f5b8aee24f777a7e8d6b4a88ac6b88927b6ec51a6b14ff2f48a33248702349f2f3a446bda3679b7c510cf6c9390b6a635721c696be3b49165dc9ca89116b2202
DIST HTML-TableContentParser-0.305.tar.gz 18931 BLAKE2B 616bfbb1809af1f0434fe3fb61082e635ba2cb62c1d14c47d059eb2c2dada80fa74ba577f85e9961036bf68f179ccc036410e2f3d67f497babbd3fe713bb6f2b SHA512 beee3b16e61b32e39bd7fdacbf993f18c1b11b6e0ba9704584243a629d72abed0012ee14518cd8c2490cb08a4c1323ee9b49ac2a764f37fa26c632a1d0ec2450
EBUILD HTML-TableContentParser-0.304.0.ebuild 384 BLAKE2B 1cab7f626ee25f51b5f680c63e0dc34defba6d201315f58dedc86d579561b09fd89bb4a2aabc27753d31067e11f15ef2a1a71664382becbfee8ca19f3bf7b6b7 SHA512 f83be083b19e5197bda0fc74b961375a749f18de4f38093d9233992fffd969018a23870748fd413805434a114578306a1c8f7ddf72285a37d7c9be0125f163c4
diff --git a/dev-perl/HTML-TableContentParser/files/0.13-test.patch b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
deleted file mode 100644
index 79916acc1e1c..000000000000
--- a/dev-perl/HTML-TableContentParser/files/0.13-test.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- t/1.t
-+++ t/1.t
-@@ -2,6 +2,8 @@
-
-
- use Test;
-+use strict;
-+use warnings;
-
- BEGIN { plan tests => 34 }
-
-@@ -20,7 +22,7 @@
-
- ## Test object creation
-
--$obj = HTML::TableContentParser->new();
-+my $obj = HTML::TableContentParser->new();
- ok(defined $obj, 1, $@);
-
-
-@@ -29,14 +31,14 @@
- ## the correct values to the callback.
-
-
--$table_caption = 'This is a caption';
--$table_content1 = 'This is table cell content 1';
--$table_content2 = 'This is table cell content 2';
--$table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
--$table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
--$header_text = 'Header text';
-+my $table_caption = 'This is a caption';
-+my $table_content1 = 'This is table cell content 1';
-+my $table_content2 = 'This is table cell content 2';
-+my $table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
-+my $table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
-+my $header_text = 'Header text';
-
--$html = qq{
-+my $html = qq{
- <html>
- <head>
- </head>
-@@ -59,7 +61,7 @@
-
-
- $HTML::TableContentParser::DEBUG = 0;
--$tables = $obj->parse($html);
-+my $tables = $obj->parse($html);
- ok($tables->[0]->{caption}->{data}, $table_caption, $@);
- ok($tables->[0]->{rows}->[0]->{cells}->[0]->{data}, $table_content1, $@);
- ok($tables->[0]->{rows}->[1]->{cells}->[0]->{data}, $table_content2, $@);
-@@ -124,16 +126,17 @@
- ok(@$tables, 2, @_);
-
- ## and three headers for each table
--for $t (0..$#{@$tables}) {
-- for (0..$#hdrs) {
-- ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
-+for my $t (0..(@$tables-1)) {
-+ for (0..2) {
-+ # ok($t, $t);
-+ ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
- }
- }
-
-
- ## and three rows of three cells each, for each table.. (18 total).
--for $t (0..$#{@$tables}) {
-- for $r (0..$#rows) {
-+for my $t (0..1) {
-+ for my $r (0..$#rows) {
- for (0..2) {
- ok($tables->[$t]->{rows}->[$r]->{cells}->[$_]->{data}, $rows[$r]->[$_], $@);
- }