summaryrefslogtreecommitdiff
path: root/dev-perl/Gtk2/Gtk2-1.249.920.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Gtk2/Gtk2-1.249.920.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Gtk2/Gtk2-1.249.920.ebuild')
-rw-r--r--dev-perl/Gtk2/Gtk2-1.249.920.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Gtk2/Gtk2-1.249.920.ebuild b/dev-perl/Gtk2/Gtk2-1.249.920.ebuild
new file mode 100644
index 000000000000..140e7da429cb
--- /dev/null
+++ b/dev-perl/Gtk2/Gtk2-1.249.920.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.24992
+inherit virtualx perl-module
+
+DESCRIPTION="Perl bindings for GTK2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ >=dev-perl/Cairo-1
+ >=dev-perl/glib-perl-1.280.0
+ >=dev-perl/Pango-1.220.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.30.0
+ test? ( x11-libs/gdk-pixbuf[jpeg] )
+"
+
+src_test(){
+ virtx perl-module_src_test
+}