summaryrefslogtreecommitdiff
path: root/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
new file mode 100644
index 000000000000..29f1002f5e8f
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=0.05
+inherit perl-module virtualx
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/glib-perl
+ dev-perl/Gtk2
+ >=x11-libs/libnotify-0.7
+"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ test? ( dev-perl/Test-Exception )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-libnotify.patch )
+
+PERL_RM_FILES=( t/notification.t )
+# the test dies if no notification daemon is present...
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ # bug 416729
+ virtx perl-module_src_test
+}