summaryrefslogtreecommitdiff
path: root/dev-perl/Graph-Easy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-perl/Graph-Easy
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-perl/Graph-Easy')
-rw-r--r--dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild34
-rw-r--r--dev-perl/Graph-Easy/Manifest3
-rw-r--r--dev-perl/Graph-Easy/metadata.xml39
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild b/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
new file mode 100644
index 000000000000..3edf63650f07
--- /dev/null
+++ b/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.76
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Convert or render graphs (as ASCII, HTML, SVG or via Graphviz)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ test? (
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"
+PERL_RM_FILES=(
+ "t/style-trailing-space.t"
+ "t/pod.t"
+ "t/pod_cov.t"
+)
diff --git a/dev-perl/Graph-Easy/Manifest b/dev-perl/Graph-Easy/Manifest
new file mode 100644
index 000000000000..7b71417e1e31
--- /dev/null
+++ b/dev-perl/Graph-Easy/Manifest
@@ -0,0 +1,3 @@
+DIST Graph-Easy-0.76.tar.gz 467184 BLAKE2B b6024a6f9e2e97d47806eb0b263af11e3e9b6b4fcb52da1107f81db51cae3d005391779e3d670daef7a8a6fd9da2cb969c6d206b5afb62f8c6b253ad882214b8 SHA512 c5f93252a047ccb0c02347f9f138217c1d52b10ba67db100de7d57a716b3da8d564ecbddedd795420eccc6fe4733bd9b3e64d1fda7d203b144c6112d6bfbe6d0
+EBUILD Graph-Easy-0.760.0.ebuild 637 BLAKE2B 492a67306d0bcd12b07603e08801336769db15a9136449492774d80915c45fde160a23e7c2d8e1d13050af2d50a943dc8693f5c8bb7c4f043e26e9df8f92994b SHA512 b0db36ed597b3fe6d28120883a0a34401292be5849f9fb04d4b4f9664a9d26ccc9d5228c48a898e1e7477fd22034beb7be364f33498015b0390e5a786d21d7e3
+MISC metadata.xml 2263 BLAKE2B c0575df05f208860f9e762a82533b40f299e0e8fefa66b9e8aab20568d0be37c75a1f598d998c513391f4788c3df46232c568deb3766e8bbc00f7b6202a6cae1 SHA512 ba213636477764dfa6352fc830ba93af2a2d0cc09c1c9881e840642f4ae1e7358055643c6b0881e85d26bcb08af7a1cc23d099edddee699f313b35a8cfc03815
diff --git a/dev-perl/Graph-Easy/metadata.xml b/dev-perl/Graph-Easy/metadata.xml
new file mode 100644
index 000000000000..979a8874c0fd
--- /dev/null
+++ b/dev-perl/Graph-Easy/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Graph-Easy</remote-id>
+ <remote-id type="cpan-module">Graph::Easy</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::As_ascii</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::As_graphml</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::As_graphviz</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::As_txt</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::As_vcg</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Attributes</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Base</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Edge</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Edge::Cell</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Group</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Group::Anon</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Group::Cell</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Chain</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Force</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Grid</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Path</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Repair</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Layout::Scout</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Node</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Node::Anon</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Node::Cell</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Node::Empty</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Parser</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Parser::Graphviz</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Parser::VCG</remote-id>
+ <remote-id type="cpan-module">Graph::Easy::Util</remote-id>
+ </upstream>
+</pkgmetadata>