summaryrefslogtreecommitdiff
path: root/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
new file mode 100644
index 000000000000..5512348e7a2b
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.049
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0:0=
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ xdg_environment_reset # bug #599128
+}