summaryrefslogtreecommitdiff
path: root/dev-perl/Geo-IP
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Geo-IP
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Geo-IP')
-rw-r--r--dev-perl/Geo-IP/Geo-IP-1.450.0.ebuild24
-rw-r--r--dev-perl/Geo-IP/Geo-IP-1.500.0-r1.ebuild24
-rw-r--r--dev-perl/Geo-IP/Geo-IP-1.510.0.ebuild24
-rw-r--r--dev-perl/Geo-IP/Manifest7
-rw-r--r--dev-perl/Geo-IP/metadata.xml19
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-perl/Geo-IP/Geo-IP-1.450.0.ebuild b/dev-perl/Geo-IP/Geo-IP-1.450.0.ebuild
new file mode 100644
index 000000000000..aa30b3aa27de
--- /dev/null
+++ b/dev-perl/Geo-IP/Geo-IP-1.450.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MAXMIND
+MODULE_VERSION=1.45
+inherit perl-module multilib
+
+DESCRIPTION="Look up country by IP Address"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/geoip"
+RDEPEND="${DEPEND}"
+
+SRC_TEST=do
+
+src_configure() {
+ myconf="LIBS=-L/usr/$(get_libdir)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Geo-IP/Geo-IP-1.500.0-r1.ebuild b/dev-perl/Geo-IP/Geo-IP-1.500.0-r1.ebuild
new file mode 100644
index 000000000000..a0cb83e4d4ec
--- /dev/null
+++ b/dev-perl/Geo-IP/Geo-IP-1.500.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MAXMIND
+MODULE_VERSION=1.50
+inherit perl-module multilib
+
+DESCRIPTION="Look up country by IP Address"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/geoip"
+RDEPEND="${DEPEND}"
+
+SRC_TEST=do
+
+src_configure() {
+ myconf="LIBS=-L/usr/$(get_libdir)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Geo-IP/Geo-IP-1.510.0.ebuild b/dev-perl/Geo-IP/Geo-IP-1.510.0.ebuild
new file mode 100644
index 000000000000..0e92f34d5e88
--- /dev/null
+++ b/dev-perl/Geo-IP/Geo-IP-1.510.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MAXMIND
+MODULE_VERSION=1.51
+inherit perl-module multilib
+
+DESCRIPTION="Look up country by IP Address"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/geoip"
+RDEPEND="${DEPEND}"
+
+SRC_TEST=do
+
+src_configure() {
+ myconf="LIBS=-L/usr/$(get_libdir)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Geo-IP/Manifest b/dev-perl/Geo-IP/Manifest
new file mode 100644
index 000000000000..8d0478700b31
--- /dev/null
+++ b/dev-perl/Geo-IP/Manifest
@@ -0,0 +1,7 @@
+DIST Geo-IP-1.45.tar.gz 134181 BLAKE2B 238c1a35a037f2729fef5586a2c5426eeea54ef1d7e499f4f68de3248fcba62e7817007704dac6329fc64498f964171f24e278777a3e699bf9c0664a8325e425 SHA512 0737459b50251f64a0230176721e6a0cf7fb701451b3488c0a0628a183233b5346b7311a80fe35752104ab6812c6791cd4bafbbfa9e7ff51aa6bd4d489655af3
+DIST Geo-IP-1.50.tar.gz 145419 BLAKE2B 2aca67893c8e9621d041be05dada458ecefbe7a6442bd501c781b3dd5dfc5c2d2dbf493a3cadcf133460bdb832e078c5708ae36320c38558a7fff0adc0b34faf SHA512 db5dc8731c970dfd9bb95312666218623453818917a9035358c7777a5077357f2b3187e07e615f1280fef53e1a7ae6336e4cf4642855b23d5326fa5772bc6462
+DIST Geo-IP-1.51.tar.gz 155629 BLAKE2B bfbbc00f53b6f564bc26252cff89e4bc97a2840c59014349c6f2af50d4130bb54068c9e96b4eecc4d7285a180da97d4da7f1c1364d36fdd3cd5f86bcd79ab17c SHA512 1149a2457a5a971a47585300ac68e71537fce4af3396aafe12ccb298b4a9e90b5fb0bc8bb01dec80698c3c57ae8e045a04c53747cc0ce80f8c4d3dd033ed76b3
+EBUILD Geo-IP-1.450.0.ebuild 459 BLAKE2B a7e2e293258809413c4df7a50e8389fdaa694fd2b6234fbbb8c099d4591ee83faca0351ff12b9d24d4c8642264cc2fae557e7d7039268916b74c35b1e0efbd4c SHA512 76e3ffcbe7b9512660645cbcc94645519f005c59994c6c78c6227d633b64b3c8578bfb250610d1365d26f348ddd6cc802275b267532027d07089fc5cf09c44d0
+EBUILD Geo-IP-1.500.0-r1.ebuild 468 BLAKE2B 6a31c1999068d4a3f02b227e21da66eb571654b976d1257fcbbe45a4ca485eb28d5114ead73e5b4ded437aeaff3487467a91d1d1e1582d400068cebf1453f1ba SHA512 d391a9152837090dae79499b3c1943212aec3342c69dc3060b4c5e80e2ef68e0633b5ec8a2860ea01a20bf796299504d91a16ec6f6ff904b24471695c395be39
+EBUILD Geo-IP-1.510.0.ebuild 461 BLAKE2B 0e7b3407ec3f13460b90e626dc2a56534f370a0bfedf023749d57e63472c021eb0bf341468da601e553c3a0eb2cf710376511b827bc62323bd679cb7dc35bd17 SHA512 d606f8b7153601deb4844cdb931f7986d5228be04b2202c54e3f229826834f30565557eaa88aa25ae1abea933453add3a3ebac31b6c5a5bbd88fbd26ade90b11
+MISC metadata.xml 718 BLAKE2B 5bd8d3847de0019659f50780299be1eb54cf7dea8a668aa93009b729ffb4537e3630b763250077fb00d8beea90077408b227b647df68884a68e88dd349d3a0dc SHA512 a3aa29c8bea6ddb5dac6a51f5e4e53e5e373e886374b1c0f3fc35c36466b9ae3cada4ddd9c09f47ac8ab93dee037331d0b897476131f09bc96e1b691dca180d5
diff --git a/dev-perl/Geo-IP/metadata.xml b/dev-perl/Geo-IP/metadata.xml
new file mode 100644
index 000000000000..d2c2ac0034fc
--- /dev/null
+++ b/dev-perl/Geo-IP/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>Look up country by IP Address</longdescription>
+ <upstream>
+ <remote-id type="cpan">Geo-IP</remote-id>
+ <remote-id type="cpan-module">Geo::IP</remote-id>
+ <remote-id type="cpan-module">Geo::IP::Record</remote-id>
+ <remote-id type="cpan-module">Geo::Mirror</remote-id>
+ </upstream>
+</pkgmetadata>