summaryrefslogtreecommitdiff
path: root/dev-perl/GDGraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/GDGraph
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/GDGraph')
-rw-r--r--dev-perl/GDGraph/GDGraph-1.490.0.ebuild19
-rw-r--r--dev-perl/GDGraph/GDGraph-1.510.0.ebuild28
-rw-r--r--dev-perl/GDGraph/GDGraph-1.520.0.ebuild28
-rw-r--r--dev-perl/GDGraph/GDGraph-1.540.0.ebuild28
-rw-r--r--dev-perl/GDGraph/Manifest11
-rw-r--r--dev-perl/GDGraph/metadata.xml25
6 files changed, 139 insertions, 0 deletions
diff --git a/dev-perl/GDGraph/GDGraph-1.490.0.ebuild b/dev-perl/GDGraph/GDGraph-1.490.0.ebuild
new file mode 100644
index 000000000000..5d321fab8bf3
--- /dev/null
+++ b/dev-perl/GDGraph/GDGraph-1.490.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=RUZ
+MODULE_VERSION=1.49
+inherit perl-module
+
+DESCRIPTION="Perl5 module to create charts using the GD module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-perl/GDTextUtil
+ dev-perl/GD
+ media-libs/gd"
+DEPEND="${RDEPEND}"
diff --git a/dev-perl/GDGraph/GDGraph-1.510.0.ebuild b/dev-perl/GDGraph/GDGraph-1.510.0.ebuild
new file mode 100644
index 000000000000..c49964dc6caa
--- /dev/null
+++ b/dev-perl/GDGraph/GDGraph-1.510.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RUZ
+DIST_VERSION=1.51
+inherit perl-module
+
+DESCRIPTION="Perl5 module to create charts using the GD module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/GD-1.180.0
+ >=dev-perl/GDTextUtil-0.800.0
+ media-libs/gd
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=dev-perl/Capture-Tiny-0.300.0
+ >=dev-perl/Test-Exception-0.400.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
diff --git a/dev-perl/GDGraph/GDGraph-1.520.0.ebuild b/dev-perl/GDGraph/GDGraph-1.520.0.ebuild
new file mode 100644
index 000000000000..1e40e88bb322
--- /dev/null
+++ b/dev-perl/GDGraph/GDGraph-1.520.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RUZ
+DIST_VERSION=1.52
+inherit perl-module
+
+DESCRIPTION="Perl5 module to create charts using the GD module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/GD-1.180.0
+ >=dev-perl/GDTextUtil-0.800.0
+ media-libs/gd
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=dev-perl/Capture-Tiny-0.300.0
+ >=dev-perl/Test-Exception-0.400.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
diff --git a/dev-perl/GDGraph/GDGraph-1.540.0.ebuild b/dev-perl/GDGraph/GDGraph-1.540.0.ebuild
new file mode 100644
index 000000000000..708e5d9fccb9
--- /dev/null
+++ b/dev-perl/GDGraph/GDGraph-1.540.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RUZ
+DIST_VERSION=1.54
+inherit perl-module
+
+DESCRIPTION="Perl5 module to create charts using the GD module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/GD-1.180.0
+ >=dev-perl/GDTextUtil-0.800.0
+ media-libs/gd
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.760.0
+ test? (
+ >=dev-perl/Capture-Tiny-0.300.0
+ >=dev-perl/Test-Exception-0.400.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
diff --git a/dev-perl/GDGraph/Manifest b/dev-perl/GDGraph/Manifest
new file mode 100644
index 000000000000..17891070450d
--- /dev/null
+++ b/dev-perl/GDGraph/Manifest
@@ -0,0 +1,11 @@
+DIST GDGraph-1.49.tar.gz 155643 SHA256 d26538c827e35c1d4b27f3c045b60f1ab6b45401c54a87e86103cd7c2374cff5 SHA512 720cc51dda41963be087bb39418642f75dade1bbab54cd4d788c18c9328f3fbd6a5c0f73027bb0be64d44cd94b0c5f2d67c48d4b0c3c34736ac8f7bc8cba95ab WHIRLPOOL 34aa2f5af03d8ce794863a7c9bbae3ad5a14a13cf85b5ecf67a4ee7ba44cfdb7036ad88b69d286198f5b3c99d75b30298321f1015d3bebd5ef545109c55bd739
+DIST GDGraph-1.51.tar.gz 156175 SHA256 0543f9549de28de05f0b40d1864cfa1f829577fad75063c45bf867d202d56123 SHA512 c9cafdc90905fea8689cac32d0429ae987a933ae090de9894c9f70668db5c636e9363e76a656898df667dd0b0b4f593a64f3327f0b8a9738f74cd2cd937005e0 WHIRLPOOL 717e90936dbe16beeff23dc85827c72a3ab32f7c2fb14f348f06bf7c30406d2c18cbb793c8103bfe1a8f2a5605201bac42b699795f7cdc84bdba2698fec24145
+DIST GDGraph-1.52.tar.gz 156349 SHA256 0d399fda24213ca6d3d6721b8818e5e0f9da2b8326b7afb5db63314d079eb8ff SHA512 9a213a5fb44608f3984ed763659fb0cb631bdbc34e89683eb3d4cb776de7fdd1cf4c9e339cf02e0035d4978bfd0d82723e1576c40720af917f50bb0363fd26e0 WHIRLPOOL 0c1e32ef3f82c715f8db0e7794ef73f3fbba7a607cfb54507bdd087d70ae089b35476704800508c45b079a8e3787682f04c22aeceb08276369abe29e0ff2236a
+DIST GDGraph-1.54.tar.gz 157158 SHA256 b96f5c10b656c17d16ab65a1777c908297b028d3b6815f6d54b2337f006bfa4f SHA512 0dd0da5fa0e879cf2addcbfdd02ee8e9e6af715b88b451dc29fe5028f30d7ba7fa0e126d07e7bb4f9a63e40b3be95a9cc0f6c061ea8644ba0ee7fdd2a7964fce WHIRLPOOL 2765719ece7bcd724257d0e0d676ddf77eb801e812504e5ea67be7ed75387f442f873c2610feb59eac89e99f0034a2103c97fe581a8141ae22f06fb204a3c26f
+EBUILD GDGraph-1.490.0.ebuild 412 SHA256 1e435f8bcb68f03794d2dfe12227cd6bc3a950977ad6d2a323bd68ccb26471a5 SHA512 4bf908c1bc55883763130bbc99008bd4419f4525b754a44793ff9fc7f63355033b4d443a5b25b08f2a03d4579e28563047f90a3090afe375b5d554d1ec99a6ba WHIRLPOOL 5728deb157550922a791507ce814f0b1b3c6789ba65b414e1d0fab004f276886279e02627526dd5089f9c8a7b5399a69a17e61e05d8d1b75e7fae52835ee3e54
+EBUILD GDGraph-1.510.0.ebuild 605 SHA256 272e77a5bb3a01bca367cbb37f7be082f60cc12e305a1ce49ab8b2ee08a2ceee SHA512 b5044eb924f1e305fcd3eafef945bd729a841f8ebc0f004162bd974c1a0d2f1786a35cfb4661d38ee06d06db174fbba1254fcbfb97cdaa712f85416412ab87ee WHIRLPOOL 97851328900e61ee43e26bc4be51701783bf7855486c6c6732430194c6f74a4fe03d586190e6873303dd52b74a993d5b9dcfe32d374864a989163dd7b20210eb
+EBUILD GDGraph-1.520.0.ebuild 605 SHA256 91d12a8f4d8328dd13bb7289e6d0fc68fe7c89fc0cfc91c06383c13fd0608fbe SHA512 cff44bc6c279c9e07d6eafe2b68693aa15aff56eb53ac0cf1441b8568786e1a63578e35e7d65213a0e5725a456ef06565fdf0f60215c88351d3d0c10cbca1350 WHIRLPOOL 1b21d369ae9530b265d9bd81a50673a0d445d10262267a6b5f2da41574452cd860e0f3716bd580ecea530f6e1f37f516e13058b296885c9389c487304024a1cb
+EBUILD GDGraph-1.540.0.ebuild 605 SHA256 cbf3134ecac3a72e6159babb2be78cecb3079d3f69edcbba0dc201f024f6f147 SHA512 9ba1dcb333fc8e4a7f8ec64fe285d222a2d339ad71d9c0f464374e863b4d7f6e6bcb9381204156997893b6eb0e20cfae425f85d994fd342e6e56274f30e47fb6 WHIRLPOOL 68d89d5b83dd08145ab66f2040c7a9d28f83b801913a7302131b420bfc438f98a119da40b0d86e9a1486c0c7774fcd65dc6de07f521f9144956f55a10bef0895
+MISC ChangeLog 3505 SHA256 fff49c22488ab9f4eb0167918f59262e304030b119a7e29182eacfc966b4453c SHA512 76fbbb950af292983ab0520f067f9764b2bbc93413657c743cb4d028a106432f3c3b13c78c3c798cc430be0d6ab61311475aac7e56e2d83a0c1fd977fb41374f WHIRLPOOL a04aaf8e7e975d74b57492b6a000995e7abfe2bffb222cbe1fa44d5527a190f0d1819e945466c48b77250285aebdbd50a02edaf7ade5c5aaf30bc1f99d549c42
+MISC ChangeLog-2015 5516 SHA256 9e5e59bd419c66947933f100b0ea5b99f43533aa00927dcbf224a8544db10b4c SHA512 008918d00eb537df5c8feef941fe68a1e3ff587f8a0bfb3da4648d36688af3422dc2974c2e2f85aadd5e1d5ac6e9176cb71418637f68a2855d4455cf563047ec WHIRLPOOL dc5acd7610c5b3678ed5d8b01737e6e39cca1cac09845e4e64f2b43c3f0fd2fb391cbc7bf179ece79a9b35dd5b492a477bec6b301a0bc1fe862fab4f84d82346
+MISC metadata.xml 1212 SHA256 5e19f0bc42f170a18ae7e9dcdbe6595908a2fa9af28464878e5f4d6f8d2c23db SHA512 6aded283f8bbaab312b2cf1e8e18e4700b05b9fe1b8f49b06390ce5421f7c9a41916782c8bb62b5334d2a0089f81a1f58e1a3c2f229f1860dce90138bd41d2fc WHIRLPOOL 63784655888da66842bbbfbc0bc5835f2db9116c7feb00c66a3d23128a8293249947ff79032ae1be621a60f7354735d6624726a6c14eb3dfd8d708b0bc97ebd0
diff --git a/dev-perl/GDGraph/metadata.xml b/dev-perl/GDGraph/metadata.xml
new file mode 100644
index 000000000000..38bd44811034
--- /dev/null
+++ b/dev-perl/GDGraph/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">GDGraph</remote-id>
+ <remote-id type="cpan-module">GD::Graph</remote-id>
+ <remote-id type="cpan-module">GD::Graph::Data</remote-id>
+ <remote-id type="cpan-module">GD::Graph::Error</remote-id>
+ <remote-id type="cpan-module">GD::Graph::area</remote-id>
+ <remote-id type="cpan-module">GD::Graph::axestype</remote-id>
+ <remote-id type="cpan-module">GD::Graph::bars</remote-id>
+ <remote-id type="cpan-module">GD::Graph::colour</remote-id>
+ <remote-id type="cpan-module">GD::Graph::hbars</remote-id>
+ <remote-id type="cpan-module">GD::Graph::lines</remote-id>
+ <remote-id type="cpan-module">GD::Graph::linespoints</remote-id>
+ <remote-id type="cpan-module">GD::Graph::mixed</remote-id>
+ <remote-id type="cpan-module">GD::Graph::pie</remote-id>
+ <remote-id type="cpan-module">GD::Graph::points</remote-id>
+ <remote-id type="cpan-module">GD::Graph::utils</remote-id>
+ </upstream>
+</pkgmetadata>