summaryrefslogtreecommitdiff
path: root/dev-perl/Font-AFM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-perl/Font-AFM
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-perl/Font-AFM')
-rw-r--r--dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild24
-rw-r--r--dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild30
-rw-r--r--dev-perl/Font-AFM/Manifest3
-rw-r--r--dev-perl/Font-AFM/files/Font-AFM-1.20-custom-test-font.patch46
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild b/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild
new file mode 100644
index 000000000000..05a0c85a67cc
--- /dev/null
+++ b/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="Parse Adobe Font Metric files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-text/htmldoc
+ )
+"
+src_test() {
+ METRICS="${EPREFIX}/usr/share/htmldoc/fonts" perl-module_src_test
+}
diff --git a/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild b/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
new file mode 100644
index 000000000000..b279f82659d6
--- /dev/null
+++ b/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="Parse Adobe Font Metric files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+BDEPEND="
+ test? (
+ media-fonts/urw-fonts
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.20-custom-test-font.patch"
+)
+src_test() {
+ # nimbus sans l medium r normal iso8859-1
+ TEST_FONT="n019003l" \
+ TEST_FONT_WIDTH="4279" \
+ METRICS="${EPREFIX}/usr/share/fonts/urw-fonts" \
+ perl-module_src_test
+}
diff --git a/dev-perl/Font-AFM/Manifest b/dev-perl/Font-AFM/Manifest
index 98c5a8a90b96..cddba08ba69b 100644
--- a/dev-perl/Font-AFM/Manifest
+++ b/dev-perl/Font-AFM/Manifest
@@ -1,3 +1,6 @@
+AUX Font-AFM-1.20-custom-test-font.patch 1345 BLAKE2B 3ac709c550233e4cd47f740b5135d055ff28090b47602970d0e55d9a5875bfb9a5275a59aac8d7a8699513518474acb5d06f409ecec5851625be4d6029f7cb5c SHA512 cfde2d260b920a3ac6a103412f6642e77851f0d8a2d8420b001430636a6b7f83aedbcf5f3e6162b11970d1957221f6d812bf6554d5a190ecd8add9ae83c22c57
DIST Font-AFM-1.20.tar.gz 10421 BLAKE2B 791b5da799811d62335b39f6d1c4e9c7b49cba83b46b4c7f1ee50a9789847a69f63f733f7d7dd319a0cd032876b04737eb671759b7dd836ac465f8e0372a85b9 SHA512 1fc74f0dbbed52937d512465a021148e93b2e0698189a6fc17eb1aa8951c934b0060a0256883118dc2a3a9086025468e0a851706306876568466bf4638fdb618
EBUILD Font-AFM-1.200.0-r1.ebuild 290 BLAKE2B 619016ec72fdf48bd961b433bde18daf2f1642b9b7e18db72076a46fae847d1baad2b24a3bd76dcea44dee010c4ec21611e1c81bc186e10e0c4419ee9f4d7c89 SHA512 37173747d9533303181c28f8c1cf54ab1c8e325f883282aae8f05c87f875691a11c075f0b62cab6a8b9a5a5813648de61331d4f2f3e5cdfc54b9eab5aa7db307
+EBUILD Font-AFM-1.200.0-r2.ebuild 429 BLAKE2B be1338530b803d49b557fa95fe58e0ab54d60116e27de4bc4e60395423e21cec68dbbd219dbe66b9e8d6f9aa98470bd569a0f0da5676a784fa5f87840cdc69ea SHA512 f945f9d9c021aeffc51fa252efecb68e62c106cff425c0135f1d2971c55f746239f5af3c78fb25b04b2e1fb3e6422a1d2185d3db86a3227d9b881e8faad9f748
+EBUILD Font-AFM-1.200.0-r3.ebuild 595 BLAKE2B e1031de82a4afff8aa49efa754a1c5845866ac480ed3733d14da36546d4e56e3d59acf75a7d0051f489ada5866987f0e341cad99051d522d80e328ba65d7a716 SHA512 5ec69841499fa95c9def60af9c76b712bdf7d8d2ce0e330a80789c6b06d2e5e84688ac1f5098dd9cda90e6700e7f12fd47c09ec864ec33def7b7ecbeddcaface
MISC metadata.xml 1285 BLAKE2B 3d500208bef6eda7f8d4c8384fe29b18d2b57a7ca38de4cedc52570b815a4d892d2434e7f6c9d9d0bef81a907b941897e9d79ad9b6ce0a76b01c0c627d2967de SHA512 287ba32c48ecd2c1f90abeb42e51db71669b851bd3e9bdd21ed6b63859f794673f59d86a32791b682ab30e2f0d3b6c21a258b24ce9f77f4a3ea0bb4a5c31fb97
diff --git a/dev-perl/Font-AFM/files/Font-AFM-1.20-custom-test-font.patch b/dev-perl/Font-AFM/files/Font-AFM-1.20-custom-test-font.patch
new file mode 100644
index 000000000000..3e674599c33f
--- /dev/null
+++ b/dev-perl/Font-AFM/files/Font-AFM-1.20-custom-test-font.patch
@@ -0,0 +1,46 @@
+From 6291356c29004b58b7d0f18ce39738ebc2412ff9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 17 Sep 2020 13:28:34 +1200
+Subject: Allow overriding test font name
+
+This allows us to use helvetica-compatible fonts without needing an
+actual font called "Helvetica"
+---
+ t/afm.t | 14 ++++++++++----
+ 1 file changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/t/afm.t b/t/afm.t
+index 40addff..60ddcb8 100644
+--- a/t/afm.t
++++ b/t/afm.t
+@@ -1,7 +1,13 @@
+ require Font::AFM;
+
++my $test_font = $ENV{TEST_FONT};
++my $test_width = $ENV{TEST_FONT_WIDTH};
++
++$test_font = "Helvetica" unless defined $test_font and length $test_font;
++$test_width = 4279 unless defined $test_width and length $test_width;
++
+ eval {
+- $font = Font::AFM->new("Helvetica");
++ $font = Font::AFM->new($test_font);
+ };
+ if ($@) {
+ if ($@ =~ /Can't find the AFM file for/) {
+@@ -18,9 +24,9 @@ print "1..1\n";
+
+ $sw = $font->stringwidth("Gisle Aas");
+
+-if ($sw == 4279) {
+- print "ok 1 Stringwith for Helvetica seems to work\n";
++if ($sw == $test_width) {
++ print "ok 1 Stringwith for \"$test_font\"(font) seems to work\n";
+ } else {
+- print "not ok 1 The stringwidth of 'Gisle Aas' should be 4279 (it was $sw)\n";
++ print "not ok 1 The stringwidth of 'Gisle Aas' should be $test_width (it was $sw)\n";
+ }
+
+--
+2.28.0
+