summaryrefslogtreecommitdiff
path: root/dev-perl/File-Which/File-Which-1.270.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/File-Which/File-Which-1.270.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/File-Which/File-Which-1.270.0.ebuild')
-rw-r--r--dev-perl/File-Which/File-Which-1.270.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/File-Which/File-Which-1.270.0.ebuild b/dev-perl/File-Which/File-Which-1.270.0.ebuild
new file mode 100644
index 000000000000..d84b87b1b9c7
--- /dev/null
+++ b/dev-perl/File-Which/File-Which-1.270.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=1.27
+inherit perl-module
+
+DESCRIPTION="Perl implementation of the which utility as an API"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test pwhich"
+RESTRICT="!test? ( test )"
+
+# Was part of File::Which, but depends on File::Which
+# so this keeps legacy integrity in place.
+PDEPEND="pwhich? ( dev-perl/App-pwhich )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.470.0 )
+"