summaryrefslogtreecommitdiff
path: root/dev-perl/File-Next/File-Next-1.160.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/File-Next/File-Next-1.160.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/File-Next/File-Next-1.160.0.ebuild')
-rw-r--r--dev-perl/File-Next/File-Next-1.160.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.160.0.ebuild b/dev-perl/File-Next/File-Next-1.160.0.ebuild
new file mode 100644
index 000000000000..3e6fbc956c15
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.160.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="File::Next is an iterator-based module for finding files"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}